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Software Versions Used in this Document

The list below describes the software versions used in this version of the course.

Software Version
PI DataLink 2019 SP1
Microsoft Office 2016

P1 ODBC Driver 2016 R2
PI SQL Client 2018 R2
Pl Integrator for Business Analytics Advanced Edition 2018 R2 SP1
Pl OLEDB Enterprise 2019
Microsoft SQL Server 2016

Pl Data Archive 2018 SP3
Pl Asset Framework 2018 SP3
Pl Vision 2019
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Analyzing Pl System Data

Lesson 1: Business Intelligence and Pl Asset
Framework

Business intelligence (BI) tools offer solutions to quickly analyze raw, un-normalized,
multidimensional data. Values from the Pl Data Archive, external metadata, and
calculations from Asset Framework can be transformed by business intelligence
tools into actionable analysis and interactive reports in order to gain insight into
business and operational processes.

One of the key concepts of the course is how Pl AF metadata and hierarchy
information inherently provides the relationships and dimensions used to filter and
slice data in Bl tools.

The Distribution Network and Fleet
Generation databases have a
comprehensive amount of information — I I
including a hierarchy of substations and
metadata for each asset. The figure to the H o - m
right depicts a data cube that captures I - I w
metadata and real-time data of generating -’

units. This data will be incorporated into a

Bl cube and used to develop interactive
reports that allow us to “slice and dice” our -‘
data and bring meaning to our

multidimensional data cube. Operator Technology  Yield  GrossGen. NetGen.

A 21 A Inclusion of additional attributes
through table lookups and analytics
on existing attributes allow for the
expansion of additional columns (or
dimensions) to the data cube above.

Y

Further, historical data, interpolated
or compressed, add an additional
dimension of information that bring
more meaning in Business
Intelligence reports.

W W

B
WS

Time
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Analyzing Pl System Data

In the next several chapters in the course, we will be using a pair of AF databases to
expose meaningful data that will help management and engineers make better, more
informed decisions.

Introduction to Power Bl

Power Bl is a business analytics service and client provided by Microsoft. It provides interactive
visualizations with self-service business intelligence capabilities where end users can create
reports and dashboards by themselves without having to depend on information technology staff
or database administrators.

Some of the benefits of Power BI:

e Less work than Excel for more complex analysis and visuals

e Can solve problems that are simply too large for Excel and Pl DataLink (MS Excel is
limited to 1 million rows)

e Cheap — Free download or $9.99 / month per user for Power Bl Pro

e Live reporting and centralized web-based dashboards in Office 365 and Power Bl Server

e Slick visuals including 3" Party Visuals in Microsoft AppSource



https://powerbi.microsoft.com/en-us/desktop/
https://appsource.microsoft.com/en-us/marketplace/apps?product=power-bi-visuals
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Activity — Inspect a Sample Power Bl Report

Objective:

o Explore a sample Power Bl Report.

Approach

We'll start by getting a feel for Power Bl using a pre-built report. Open C:\Class\Part 1 - PI
Integrator for BA\Sample Report.pbix

Transformer High Loading

High Circuit Loading Pole Transformers

-] PTXYZ0103 X Phase 2208 13050 @
. PT_XYZ0311 X Phase 2208 12220 @
PT_XYZ0377 7 Phase 2208 17211 @
I PT_XYZ00%6 X Phase 2208 11699 @
PT_XYZ0884 7 Phase 2208 10306 @
PT_XYZ0566 Y Phase 2208 9666 @
I PT_XYZ0O71 Y Phase 2208 9568 @
PT_XYZ0410 7 Phase 2208 95294 @
PT_XYZ0644 X Phase 2208 8780 @
PT_XYZ1470 X Phase 2208 8337 @

PT_XYZ0126 X Phase 2208

PTXYZ0S85 X Phase 2208
PTXYZ0428  ZPhase 2208

PTXYZ0254 X Phase 2208

PT_XYZ0135 Y Phase 2208

B E - E B PT_XYZ0210 X Phase 2208

Loading (25%) ©150 ®175 ®200 225 @250 @275 PT XYZ0587 X Phase 2208
PT_XYZ0063 X Phase 2208

PT_XYZ0055 Y Phase 2208

PTXYZ0608 X Phase 2208

Ji J

Right now we’re looking at the Report View where the report and visuals are configured. Start
clicking on the visuals and the rest of the report will be filtered to only include the selected items.
This is often referred to as slicing and dicing the data.

Tl
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Analyzing Pl System Data

Click on the Data Tab to inspect the data set we’ll be working with:

File Hoeme Insert Modeling View Help
+ B
Ele [® (bE B 2 5 kg E
Paste Get Excel PowerBl 50L Enter Recent Transform Refresh Mew  Text Maore M
data v datasets Server data sources~ data v visual box visualsv mei
Clipboard Diata Jueries nsert
ol

= Transformer

High Circuit Loading

Parque 5an Jose I
Colegio Cientifico .

Note that all the columns are available in the Fields List:

Sample Report - Power Bl Desktop

File Home Help Table tools Column tools
&) Name | Transformer Loading @
Mark as date New  Quick MNew New
table ~ elat measure measure column table
Structure Calendars Relationships Calculations D
W X Vv Fields >
= | Hour |~ | Substation |~ | Single Transformer |~ Circuit ~ | Phase |~ | Secondary Transformer |~ | Loading |~ | Maxi
E 27 0| San Pablo Transformer 1 Escuela Joaguin | X Phase PT_XYZ1579 5232 2 /O Search
27 1| 5an Pablo Transformer 1 Escuela Joaguin | X Phase PT_X¥YZ1579 4.756
ﬂg 27 2| 5an Pablo Transformer 1 Escuela Joaquin | ¥ Phase | PT_XYZ1579 12536 ~ B Transformer Load...
27 3 | San Pablo Transformer 1 Escuela Joaguin | X Phase PT_¥YZ1579 8.764 Circuit
27 4 | 5an Pablo Transformer 1 Escuela Joaquin | X Phase PT_X¥YZ1579 11.096
27 5| 5an Pablo Transformer 1 Escuela Joaguin | ¥ Phase PT_¥YZ21579 354 = Day
27 & San Pablo Transformer 1 Escuslz Josouin ¥ Phase  PT_XYZ1579 10912 M2 Day Name
7 7 San Pablo Transformer 1 Escuela Joaguin | X Phase FT_XYZ157% 4872 Headquarters



Analyzing Pl System Data

Go back to the Report View, click on the Pole Transformers Table visual, and note the Filters
Pane, Visualizations Pane, and Fields Pane. These sections are where the bulk of the
configuration takes place. Columns from the data set are dragged and dropped from the Fields
Pane onto the various sections in the Visualizations Pane. We can see that the Secondary
Transformer, Phase, Service Hours, Average of Loading, and PI Vision columns are being
displayed in the table.

% Filters @ >  \Visualizations > Fields >
/O ISearch E L L = /D search
Filters on this visual o [ i L) | ~ B, Transformer Loa...
Average of Loading s 2 | = O Circuit
T E | O/ Day
o ® [ Day Name
nase
is (A} lzn'—' @\ O Headquarters
~ []% Headquarte..
Pl Vision L s Feadauare
) O3 Hour
is (All} Secondary Transformer v X
Oz id
Secondary Transforme Phase v ¥ E Loading
top 20 by Average of... Service Hours R A} Loading (25...
Average of Loading R e
Service Hours OZ Madmum..
is (Al LU R 0= Month
O Month Name
Add data fields here Drill through & Phase
Cross-report <[ PIVision
Filters on this page . off O— [JE PlintshapelD
X PlintTSTicks
Add data fields here Kecplaliies [0 = Rated KVA
off O— = Secendary ...
Filters on all pages ... | Add drill-through fields here B Szt

O Single Trans...
Add data fields here O Substation
v O TimeStamp

Tl
If
]
\

OSlsoft. Page 7
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Minimize the Filters Pane for now.

Y Filters @ Visualizations > Fields >
P search E |£ : |-|-l E [lll 2 search

gl > W T
Filters on this visual il = kx b o EH  ~ E Transformer Loa..
Average of Loading @R m@EEE O Circuit
is (A vy [ RPE O day

@ M2 Day Name
Phase

is Al =T @ O  Headquarters

v %o
Values [J% Headguarte..

.
Pl Vision 0= Hour

Add the Voltage Average column to the table by selecting the table and doing a drag and drop:

<] Visualizations > Fields >
<] EMEDhEN O search
o b -
ﬁ? |'l_ P E' Transformer Loa...
1
wi Fa’
et O Circuit
T M Day
(-

O Day Name
O Headquarters

~w % Headquarte...

Values
X Hour
Secondary Transformer ~ X O 14
Phase s “ X Loading
Service Hours R4 Ol et S
Average of Loading R 4 Dé Maximum
Pl Vision R 4 0= Meonth
Vaoltage Average RV 4 0 Month Mame
d Phase
Drill through S Bl vision
Cross-report = PlintShapelD
0FF O (X PlintTSTicks
= Rated KWA
Drag and drop, or just - Secondary ...

check the box

“ B Service Hou...

O Single Trans...

O Substation
~ O TimeStamp

Add drill-threugh fields here

O Transformer...

~ X Voltage Ave...
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Resize and/or reposition the visual so that the Voltage Average column is visible.

(o | — > o7 11

Pole Transformers

Secondary Transformer  Phase Service l—oio" Voltage Average

Loading
PT_XYZ0109 X Phase 2208 13050 @ 362,473.77
PT_XY¥Z0911 X Phase 2208 12220 @ 534,218.20
PT_XYZ0377 Z Phase 2208 117.11 @ 546,361.94
PT_XYZ0096 X Phase 2208 11699 < 541,711.65
PT_XYZ0834 Z Phase 2208 103.06 @ 541,607.03
PT_XYZ0566 Y Phase 2208 96.66 @ 531,744.63
PT_XYZ0071 Y Phase 2208 95.68 @ 541,635.89
PT_XYZ0410 Z Phase 2208 9294 @ 544,598.67
PT_XYZ0644 X Phase 2208 87.80 @ 530,424 '
PT_XYZ1470 X Phase 2208 8337 @ 527’2%
PT_XYZ0126 X Phase 2208 Grabed:rse«:?lc;comers E; ,169.24
PT_XYZ0589 X Phase 2208 TTOS S
PT_XYZ0428 Z Phase 2208 81.24 @ 54NM167.24
PT_XYZ0254 X Phase 2208 81.08 @ 526,407.05
PT_XYZ0195 Y Phase 2208 80.18 @ 537,3%5.93
PT_XYZ0210 X Phase 2208 79.63 @ 541,671.41
PT_XYZ0587 X Phase 2208 7953 @ 53117283
PT_XYZ0063 X Phase 2208 7823 @ 539,603.
PT_XYZ0065 Y Phase 2208 7801 @ 534,644.2
X Phase 2208 7636 @ 531,702.44

PT_XYZ0608
[

|

The Voltage Average will be displayed in the table, but by default all the voltages from all the
rows will be summed by transformer. It makes more sense to summarize these as an average,
so click the drop down and change the summary to Average:

OSlsoft.
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T

Values

@

Secondary Transformer “ X

Phase

Service Hours

O

X

Average of Loading R4

Pl Vision

O

Remaove fisld

Average of Voltage f-'w

Rename

Maove

Conditional formatting

Don't summarize

Sum

Minimum

Remove conditional formatting

Resize the column directly on the visual similar to Excel:

10

Pole Transformers

T - A f Pl Visi A f Vol
=y ren |1 Slide all the way to the right r L::;s;‘j sen Ai:g:o iEzs i
(20109 X Phase 2208 13050 @ /ﬁﬁ
(20911 X Phase 2208 12220 @ 24195
(20377 Z Phase 2208 T17.1] dhen e | 247.45
(20096 X Phase 2208 11699 24534
(20884 7 Phase 2208 10306 @ 245.29
(0566 Y Phase 2208 96.66 ® 240.83
(20071 Y Phase 2208 9568 @ 24531
(20410 Z Phase 2208 9294 @ 246.65
(20644 X Phase 2208 8780 @ 240.23
(21470 X Phase 2208 8337 @ 238.83
(20126 X Phase 8292 ® 24238
(20589 X Phase 8163 @ 240.70
(20428 7 Phase 8124 @ 245.09
(20254 X Phase 8108 @ 23850
(20195 Y Phase 80.18 @ 24336
(20210 X Phase 7963 @ 24532
(20587 X Phase 7953 @ 240.57
(Z0063 X Phase 7823 ® 24439
(20065 Y Phase 7801 @ 24214
f7Z0RNS ¥ Dl SHEEE (=2 240 91 N
< |
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Average of Voltage Average is a pretty weird header name, so double click it and rename it to
Average Voltage:

Other Formatting Options are available by clicking the paint roller icon:

I3

siad

T @

Yalues

Secondary Transformer - X
Phase O
Service Hours W
Average of Loading W
Pl Vision WX
ge .':tagel X

B e
Hyve

Visualizations >  Fields

= il 2 search

i i i
[l e LA, ~ B Transformer Loa...
e 8 Yy L 5 (] Circuit
FE 3 & O sy
N - om Day Name
@ O Headquarters
“ [J% Headquarte...
52 search O3 Hour
“ General Oz
* X Loading
Sy D'@‘ Loading (25...
v Grid 0= Maximum ...
O Z Month
~ Column headers = .

OSlsoft.
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We’ll go over more formatting options in the exercises, so for now just bump up the text size of
the column headers to 12:

Headquarters

? @ 3 Headquarte...
O sSearch
Hour
~ General =
Loading
s @l Loading (25...
« Grid Maximum ...
Maonth
Column headers Month Name
Font color - Phase
m- “ [ Pl Vision
[JZ PlintshapelD
Background ccler [JX PlintTSTicks
O~ [J X Rated KVA
v Secondary ...
ST < B Serice Hou..
Bottom anly

O Single Trans...
O Substation
~ [0 TimeStamp

Auto-size column width

On —@
O Transformer...
Font family “ X Voltage Ave...
Segoe Ul O = voltage Ma..
0= voltage Mi...
. X Voltage Qu...
X Weekof th..

12
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Adjust the column widths and reposition the visuals to make everything fit. Your report should
now look something like this.

Transformer High Loading

High Circuit Loading Pole Transformers
Secondary  Phase Service Average of Pl Vision Average
Parque San Jose . Transformer Hours  Loading Voltage
-~
Colegio ¢ ifico . PT_XYZ0109 X Phase 2208 13050 @ 16416
R PT_XYZ0911 X Phase 2208 122.20 @& 241.95
Angels Basilica I
PT_XYZ0377 ZPhase 2208 17.11 @ 24745
Merced District PT_XYZ0096 X Phase 2208 116.99 @& 24534
Museo de los Ninos PT_XYZ0884 Z Phase 2208 103.06 @ 245.29
PT_XYZ0566 Y Phase 2208 96.66 = 240.83
Universidzd PTXYZOOT1 YPhase 2208 9568 @ 245.31
Escuela Joaquin PT_XYZ0410 Z Phase 2208 9294 @ 246,65
PT_XYZ0644 X Phase 2208 87.50 @ 240.23
Turistico Montezumg PTXYZ1470 XPhsse 2208 8337 @ 23883
Cementerios PT_XYZ0126 X Phase 2208 8292 @ 242,38
PT_XYZ0589 X Phase 2208 81.63 @ 24070
Paseo Colon
PT_XYZ0428 Z Phase 2208 81.24 @ 245,09
[ 600 800 e PT_XYZ0254 X Phase 2208 81.08 = 238.50
>
Loading (25%) 150 175 PT_XYZ0195 Y Phase 2208 80.18 24336
PT_XYZ0210 X Phase 2208 79.63 @ 24532
PT_XYZ0587 X Phase 2208 79.53 @ 240.57
PT_XYZ0063 X Phase 2208 7823 @ 24439
PT_XYZQ05 Y Phase 2208 780 @ 24214
lune July August
PT_XYZ0608 X Phase 2208 76.36 @ 240.81

We will build a similar report from scratch in a future exercise.

( OSlsoft. Page 13
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Lesson 2: Power Bl Reports using Pl Integrator for
BA

We will be working with a data set for a power distribution company, which includes
electrical characteristics for over 1500 single-phase transformers. The source data
will be published in a data-science ready format using PI Integrator for BA. Once this
is done, we'll configure an array of Power Bl visuals and integrate the results with Pl
Asset Framework and PI Vision.

The transformers we will be analyzing are secondary transformers that deliver power
to homes and businesses, which you may have seen on a pad or pole in your own
neighborhood. There are thousands of them to keep track of, making this a difficult
problem to solve using Excel.

The transformers themselves are not actually instrumented. The power and voltage
characteristics we will analyze have actually been computed by rolling up child
Meters in Pl AF.

Pl AF Hierarchy and Data Set

Objective:

e Better understand the data set used in the following chapters

We will take a few minutes to understand where the data set came from and relate the sample
Power BI report back to the PI System. We are working with a data set for a fictitious power
distribution company. They have built a Pl AF Hierarchy for their transformers and meters
serving a number of geographical areas. In this course, we will focus on analyzing the
transformers.

14



Analyzing Pl System Data

Open PI System Explorer and head to the Distribution Network AF database. Drill down to a
level with transformers (names starting with PT_) and inspect the available attributes. We will be
using a sub-set of these attributes for all of our analysis, in addition to leveraging the AF
hierarchy.

Note that because the Transformers are not instrumented, Voltages, Voltage Quality, and Wh
Delivered are rolled up from the child meters using Asset Analytics.
) \\PISRVOT\Distribution Network - P| System Explorer (Administrator)

File Search View Go Tools Help
@ Database [ QueryDate ~ © @5 | Back H, Checkin <3 « [£]Refresh |3 New Element = =1 New Attribute

Elements PT_XYZ0343
i Elements General Chid Elements Attributes Ports  Analyses Notification Rules  Version
- @ Alajuela
= @ Avenida Central
£ (@ Transformer 1 Fiter
= (J Colegio Cientifico 2 ¢ @ &R Name 2| Value
- (X Phase T 1
- &9 PT_XYZ0343 | =1 Connection Py
- &9 PT_XY20378 ”
= =1 Feed 01
& PT_Xv20380 b
&9 PT_XYZ0381 L] =1 Load Control Point 05171
&9 PT_XYz0387
- &9 PT %7038 L} =1 Loading 11,564 %
- PT_XYZ0383 =1 Maximum KVA 8.3
- &9 PT_XY20330
&0 PT_XY20393 L} =1 Phase X
&9 PT_XY20395 a ’
5 PT xvz0385 =1 Rated kvA 25
- ) PT_XY20357 =1 subDistance oft
- &9 PT_XYZ0415
- 53 PT_XYZ0415 =1 Substation 0856
&0 PT_XYZ0417 a .
B Pixvzons =1 Transformer Type POLE
&9 PT_XYZ0419 B & | ¥ voltage Average 247,583333333333 V
- @ ¥ Phase
- 9 7Phase s BE | F Voltage Maximum 248,050003051758 V
(G Cartago s B % | ¢ voltage Minimum 247.324996948242 V
@@ Heredia
(J San Jeronimo s B@ | ¥ voltage Quality 114,609953552419 %
- & San Jose z 7
- & Secondary Transformers =1 Voltage Standard Deviation 0
- (§ Service Delivery Paints 5 € | ¢ whDelivered Load 2891 Wh
(£}, Element Searches

Data from this Pl AF hierarchy will be published for use in a Power Bl report in a later
exercise.

o
If
]
{

OSlsoft. Page 15
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Lesson 3: Pl Integrator for Business Analytics

In simple terms, PI Integrator for Business Analytics reads data from Pl Asset Framework and
writes the data to a variety of 3"-party platforms and databases referred to as Targets. The
most often used target is a Microsoft SQL Server database.

Getting the data out of the AF structure and into the client tools requires the use of integration
software such as the PI Integrator for Business Analytics or Pl System Access software. This
chapter will discuss the former method of extracting the data.

The PI Integrators join your Business Intelligence (Bl) infrastructure with OSlsoft's Pl System,
allowing you to combine high-value Operation Technology (OT) data from the Pl System with
Information Technology (IT) data for reporting, analytics, and application integrations. The
integration of data from OT systems, such as automation and control systems and internet-
enabled devices, with data from IT systems, such as transactional and business process
systems, increases situational awareness, adds transparency into industrial operations and
business processes, and makes it possible to anticipate problems and identify opportunities for
process improvements.

Product Information and Features

The section outlines general product, feature, and component information. The latest
documentation can be found in the Pl Live Library.

Advanced vs Standard Edition

PI Integrator for Business Analytics Advanced Edition serves real-time packets of Pl
System data to streaming platforms such as Apache Kafka. Streaming platforms
assist in operationalizing machine learning models and support Kappa and Lamda
architectures for data consumption.

In short, Advanced Edition supports streaming views while Standard Edition does
not.

Pl Asset Framework Requirement

PI Integrator for Business Analytics requires a Pl Asset Framework (Pl AF) model to
select Pl System data to produce decision-ready data. The data can be cleansed
using a variety of filters and enhanced with asset, event, and time context from the PI
System.

PI Tags cannot be used directly. They must be mapped in Pl AF in order to be
exposed with Pl Integrator for BA.

16
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Licensing by Streams

PI Integrator for Business Analytics is licensed by stream count. A stream is a unique
instance of a Pl Tag used in one of the PI Integrator views. If the same tag is used in
multiple views it only counts as one stream. Publishing static attributes does not
consume streams.

General Software Architecture

Consult the PI Live Library for the latest documentation. The system architecture for
PI Integrator for BA 2020 from the online documentation is shown below:

!
11
Lol T

Client with
Pl ODBC Driver [ Represents separate processes

pm  Represents required services

Plintegrator
database with
Pl Views

Hadoop Azure MSSQL| &» & @

Destination Targets

The PI Integrator for BA architecture can be confusing because it typically has
components on 3 separate servers and that’s not even counting Targets:

o All the roles in blue always exist on a single server and represent a set of
Windows Services and the Web Page used to configure and administer Pl
Integrator for BA.

¢ Pl Integrator for BA has backend components in a Pl AF Configuration
database which are separate from the elements and attributes used as data
sources.

@ OSlsoft. Page 17
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e Pl Integrator for BA has 3 backend databases on a Microsoft SQL Server:
PlintegratorDB, PlintegratorLogs, and PlintegratorStats. These are separate
from any configured SQL Server targets.

Targets

As of the PI Integrator for BA 2020 release, the following Targets are supported by
the Advanced Edition:

Amazon Kinesis Data Streams
Amazon Redshift

Amazon S3

Apache Hive

Apache Kafka

Azure Data Lake Storage Gen 1
Azure Event Hubs

Azure 10T Hub

Azure SQL Database

Azure SQL Data Warehouse
Google BigQuery

Google Cloud Storage

Google Cloud Pub/Sub

Hadoop Distributed File System (HDFS)
Microsoft SQL Server

Oracle

SAP® HANA® ODBC

Text file

PI View (configured out of the box)

In this course we will only configure PI Integrator for BA to publish data to the
Microsoft SQL Server target.

The PI View Target

The PI View target is the only target that is configured out of the box. Technically the
view data is stored in a SQL Server since it exists in the PlintegratorDB database,
but the supported access method is to use the PI ODBC Driver on the client querying
the PI View. Pl Views mainly exist for convenience and having a readily available
Target when the installation completes. It is intended for testing and development
sandbox scenarios only and should not be used if a Microsoft SQL Server target is
available.

18
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Architecture Used in Class

In this course, all server roles including Pl Data Archive, Pl AF Server, SQL Server,
and PI Integrator for BA are all installed on PISRVOL. In a production grade
architecture, each role would typically have its own dedicated server.

== -PISRV0d- — = = = — = = = = = o e

SQL Server
Publish Target |

,—PICLIENTOL ------ <

\

| : SQL Server
: | Provider
T

SQL Serve

Worker Node

P Integrator for BA:
e WebUl ] ('

/
|

|

|

|

|

|

|

|

: Pl AF Server &

I PI Data Archive

: e PIAF Databases (static data)

: e Pl Points (time series data / tags)
\

Client Machin
e Microsoft Power BI
e Pl Software

N |

L. |

|

rﬁ l
Relational tables :
|

|

|

The PI Integrator for BA Web Page and Windows Services on PISRVO01 are:

@ Advanced Edition

< c

x +

@ pisrv01.pischoolint:444

My Views

4. PISCHOOL\student01 &

+ Create Asset View
Build 2 data view starting with
your asset hierarchy

+ Create Event View

Build a data view starting with
your event frame hissarchy

+ Create Streaming View

Build 2 streaming view with a

custom output shape

Modify existing data view

Remove selected view
Name Run Status Type Run Mode Start Time
Distribution N... @ Published Asset Once 01-Jun-17

End Time
31-Aug-17 23:... Apr 30, 2019 _.

Last Run Time

&4 Pl Base bubsystem

C5.P| Buffer Subsystern

-.‘.‘,;);PI Integrater Framewaork
-.‘.‘,;*;PI Integrater Sync

-._.“;*;PI Integrater Worker Nede 1
‘5Pl License Manager

\_.“IQ;PI Message Subsystem
-._.“'Q;PI MNetwork Manager
-J_‘,?;PI Notifications Service
Q;PI OLEDB Enterprise Agent
-,‘_‘,Q;PI Performance Equation Scheduler

-J_‘,;‘:PI Ramp Soak Simulator (rmp_sk) Interface X64
QEPI Random Simulator (random) Interface X64
».‘:;‘EPI Recalculator Subsystem

».‘:;‘EPI Shutdewn Subsystem

c.pl Snapshet Subsystem

-.‘:.,(*;PI S0L Data Access Server (Pl Integrator Framework)
"5 PISOL Data Access Server (RTQP Engine)

-.‘.‘,;*;PI 50L Subsystem

& Pl Totalizer Subsystem

\_.“IQ;PI Update Manager

=

( OSlsoft.
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The PI Integrator for BA Configuration database element is:

|2 v\PISRVOT\Configuration | Pl System Explorer (Administrator)

File  Search View Go  Tools Help
aDatabase [ Query Date ~ (U @ ) Back ) |H, CheckIn

Elerments

5 Elements
= @ Oslsoft

freeens i ht
I (& PI Integrator for Business Analytics

- B9 PLSQL
- (5 PIWeh APT
- (5 PIANO

- [ RTQP Engine

e - ]

The backend SQL tables are:

Object Explorer > 0 x
Connect~ ¥ ¥ VI

. (S0L Server 13.0.1601.5 - PISCHOOL\student01)

= Databases
Systern Databases
Database Snapshots
g FlectGeneration
W PIFD
Plint
gl PlintegratorDB
g PlintegratorLogs
W PlintegratorStats
W FlVision
gl ReportServer
g ReportServerTempDB
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The SQL Server Target database is:

Object Explorer > QX
Connect~ ¥ ¢ -

=W =1 (SOL Server 13.0.1601.5 - PISCHOOL\student01)
= Databaszes

Systern Databases
Database Snapshots
FleetGeneration
PIFD

Plint

PlintegratorDE

-

-

g PlintegratorLogs
g PlintegratorStats
g PlVision

@ ReportServer
=]

BEEBHBH

ReportServerTempDB

2]

The SQL Server target configuration is in the Target section of the Administration
page:

Administration

AF Databases Users Licensing Logs Views Cluster Manager Schema Registry Browser

Publish Target Configuration
Publish Targets H Target Configuration @

Bl View Hostname PISRVO1
S0L Authentication Username
SQL Server Username sememe

S0L Authentication

Password
Password

Publishing Timeout

The time allotted for publishing data to the target before the

Use High Availability [}

"E" Add Publish Target 'E:' Remave Publish Target

In this course we will only configure PI Integrator for BA to publish data to a SQL
Server and then use the native SQL Server provider to import the data into Microsoft
Power BI.
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Pl Integrator Web Ul

The PI Integrator for Business Analytics site can be accessed via
https://pisrv01.pischool.int:444 or from the desktop. If prompted for credentials, enter
your student account, as this has been given access rights.

Views can be created within the Pl Integrator portal that is hosted on PISRVO1.A list
of previously generated views is present within the portal on the My Views page,
allowing for previewing and maintenance. These existing views can also be cloned
and modified, allowing different views to be created and utilized within BI client tools.
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The following is a breakdown of the My Views page layout, and the different
operations available.

Note: The information regarding the My Views page layout is available within the PI Integrator
for Business Analytics User Guide.

= My Views 4. PISCHOOL\student01 &

+ Create Streaming View ‘@ Modify View

Name Run Status Type Run Mode Start Time End Time Last Run Time E

+ Create Asset View + Create Event Vi X Remove
B ting witty B Remove 2e

Distribution Network Sample @ Published Asset once 01-Jun-17 31-Aug-17 23:00:00 Apr 30, 2019 9:43:30 PM
—mE

Overview ~ Log@®  Security  View Configuration  Statistics
Run Status o Published Asset Shape
View Name # Distribution Netwark Sample “ Qreadgquarters

4 () substation
PI AF Database Distribution Network

4 @ single Transformer

Publish Target Pl View 4§ creui
View Type Asset 4 @ Phase
Run Mode Once 4 (@ single Phase Transfermer
Last Run Time Apr 30, 2019 9:43:30 PM SLoading

Your Start Time is 01-Jun-17 S Maximum Kva

The My Views page shows details about your views.

All the views to which you have access are listed in the table

Click to create an Asset View that is based on Elements and Element Templates

Click to create an Event View that is based on Event Frames and Event Frame Templates

Click to create a Streaming View for publish targets that support streaming such as

Apache Kafka, Azure Event Hub, and Azure loT Hub.

To modify a view, select the view in the table and click Modify View.

To delete it, click Remove View. Deleting a view removes data from the buffer, therefore

freeing up space. However, this does not free up the available output streams allowed with

your license.

7. For the selected view, the Overview, Log and Security tabs provide additional details about
the view.

8. The red message counter icon at top right show that there are warning and error messages
recorded by PI Integrator for Business Analytics. Click the icon to open the message list.

9. Click the gear icon at top right to see the version of Pl Integrator for Business Analytics and

AF you are using.

PwbdE

o a
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Activity — Create the Transformer Loading View
Objective:
e Use the PI Integrator for Business Analytics to create an Asset View, which
will be used in later exercises.

Approach:

Open Google Chrome and Navigate to the PI Integrator for BA Web Ul at
https://pisrv01.pischool.int:444

Go back to My Views:

= PI Integrator for
Business Analytics
Advanced Edition

Pl My Views

Manage your data views

Click Create Asset View and name it Transformer Loading, click Create View:

i@ Advanced Edition X -+

C B https://pisrv01.pischoolint:444

Create New Asset View

Asset View Name

Transformer Loading|

cance'

Click Create a New Shape

Create a Maw Shape

24
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Select Distribution Network as the AF Database, then drill down to PT_XYZ0343.

@I Source Assets

Server

Database

) Assets

E ) Alajuela

E@ Awenida Central

w @S&ar{

FIERW1

v

Distribution Metwork

@

E@ Transformer 1
E@ Colegio Cientifico
Eﬁ:’) X Phase

P [ PT_XvZ0343

-~

Drag and drop Alajuela to the Shape Builder

Transformer Losding

T Asst

Select Data > Modify View > Publish

v @ Search Shape

To Asset Shape

Autodrop and place

> o

@ScurceAsseis

S PISRVOL v
Database Distribution Metwork oo
) Assets

||‘ @ Alajuela I —_— |

4 [ Avenida Central

4 [ Transformer 1

4 [ Colegio Cientifico

4 () Phase

» (D PT_XvZ0343

OSlsoft.

Page 25



Analyzing Pl System Data

Edit the Filter on Alajuela:

Select Data > Modify View > Publish

@ Source Assets v @ Search Shape
Sanvar ISRV . T Asset Shape
Deilees Distribution Metwark ooy el
) Assets

“ 6 Alajuela | -

—_—

Clear the Asset Name Checkbox, Change it to filter on the Headquarters template, click Save:

26
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¢ fsset Template
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Asset Category

(+) Add Filter
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Drag and drop Avenida Central to the Shape configuration, and change it to filter on
the Substation Template:

Edit Filters x

Agget Mame

‘ Avenida Central ‘

¥ Asset Template Search Derived Templates

Substation

Asset Category

DSCADA

() Add Filter

Repeat this pattern for Transformer 1 (Template = Single Transformer), Colegio
Cientifico (Template = Circuit), X Phase (Template = Phase).

Drag and drop PT_XYZ0343 and select Secondary Transformer as the Template,
this time check the box to search derived templates.
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Edit Filters ®

Asset Mame

PT_XYZ0343

< Asset Template ¢ Search Derived Templates

Secondary Transformer | v

Asset Category

Single Phase v

(+) Add Filter

The shape configuration should look like this:

@ Search Shape
T Asset Shape
- @Headquar‘tera
4 [ substation
4 ([ single Transformer
4 [ Circuit

4 [ Phase

% % %W % %K
X X X X X X

4 ﬁj Sacondary Transformer

Click PT_XYZ0343 then hold control and multi-select Loading, Maximum KVA,
Rated KVA, Transformer Type, Voltage Average, Voltage Maximum, Voltage
Minimum, Voltage Quality, and Wh Delivered Load. Drag and drop these
selections to the Shape configuration.
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Transformer Loading

Select Data > Modify View > Publish

@ Source Assets v @ Search Shape
T Asset Shape
S PISRVDT v = ?
Database 4 D Headquarters
Distribution Nebwark = v

4 [ substation

& n

# %

D Assets 4 @ Single Transformer S %

4 (D Alajuela 4 [ Cireuit s, %

4 [ Avenida Cantral 4 @ Phase £ %

4 @ Transformer 1 4 (D Secondary Transformer & x

4 (3 Colegio Cientifico [=] Loading %

4 @ XFPhase =] Maximum KVA S0

| 4 @ PTxVz0343 = Rated KVA £ %

) MTR_KIEZH313771 i T %

() MTR_K1EZH313773 - & Voltage Average & x

- —=N & Voltaga Maximum & %

A11ribuIEs|Fmgr x|z # voltaga Minimum £ %

O Bl A 4 voltaga Quality # %

=) SubDstance e . & Wh Deliverad Load # %
[=] substation [i]
[=] Transformer Type (1]
# voltage Average [}
OVchageMaxlmum [i]
o\luhageMlmmum [1]
# Veltage Quality [:]
VchageStandard Daviation (i ]

I 4 vwh Deliverad | oad ﬂJ

Note that all Transformers share these common attributes because they all use the
same template.

There should be over 100 matches in the preview, click Next in the top right corner.

+ Matches
Found 100+ Matches

. » D Alajuela

s
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We now see a preview of the data using the default Time Range and interpolation
mode. Note that each AF attribute is a column in the preview. Pl AF templates
inherently provide the table format preferred by Bl Tools when analyzing a number of
similar assets.

4~ L PISCHOOL\student01 &

Select Data » Modify View > Publish
= Edit Value Mode Start Time End Time

+ Add Column ¥ Edit Row Filters
16 columns v Fikier

0 Row Fiiers

Headgquarters TimeStamp Substation Single Transformer Circuit Phase Secondary Transformer Loading Maximum KVA Rated KVA Transformer Type Voltage Average Voltage Maximum VOItang
Alajuela 5/13/2019 6:49! Avenida Centri Transformer 1 Colegio Cl X Phase  PT_XYZ0381 12552 37 25 {POLE 247 196 247 275 24715
Alajuela |5/13/2019 6:50! Avenida Centr: Transformer 1 Colegio Gi X Phase | PT_XYZ0381 12552 3T 25 ‘POLE 247.196 247275 247.15
Alajuela 5/13/2019 6:51! Avenida Centri Transformer 1 Colegio Ci)( Phase ' PT_XYZ0381 12552 37 25 :F‘OLE 247 196 247 275 24715

We want to publish Hourly data for the time period 01-Jun-17 00:00:00 to 31-Aug-17
23:00:00. Modify the Start Time and End Time and click Apply:

Start Time End Time

01-Jun-17 31-Aug-17 23:00:00

aase Transfarmer Loading Maximum KVA Rated KVA Transformer Type Woltage Average Voltage Maximum Voltage [ =

1381 1128 317 25 EF'OLE 248 547 5249.575 5249.425

Click Edit Value Mode and change the time step to 1 hour, then Save Changes:

Edit Value Mode ®

® Sampled Values

® Sample values every |+« | hours+

® Interpolate o
Exact &

Uze Key Column | Voltage Average Y
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The TimeStamp column should now reflect changes to the Start, End, and Value
Mode:

# Add Column Y Edit Row Filters i= Edit Value Mode
18 ezlumns O Row Filters Interpclated Values
Every 1 hour

rFi

>
Headguarters TimeStamp }ﬁbstatiun Single Transformer Circuit Fhase |Sil
Alajuela EBHJ‘QDW 12:00:00 A ﬁwenida Central: Transformer 1 éCEﬂEgiD Cientifico {¥ Fhase | F1
Alajuela §8f1f2|:|1? 1:00:00 AM éAvenida Central | Transformer 1 éCEﬂEgiD Cientifico {¥ Phase | F1
Alajuela EBHJ’QDW 2:00:00 AM éAvenida Central: Transfarmer 1 éCD|EgiD Cientifica {* Phase | P1
Alajuela EBHJ‘QDW 3:00:00 AM éAvenida Central | Transformer 1 éCEﬂEgiD Cientifico {¥ Fhase | F1
Almiviml= EL'-!H 04T A-00-00 Ahkd I Msmmidlm T A s T e F e e Er‘“nlnnin im0 Dlem - 107

Now we’ll add some additional time columns that will come in handy later when
building the reports. Click Add Colum. Select the Time Column tab. Select Month,
Month Name, Week of the Year, and Hour, then click the arrow to bump them over to
the right:

Add Column

Data Column Time Column Static Value
Select Time Column Options for | Local ¥
Year(2020 TimeStamp(Loca
Month(4)

Month Name(April)
Week of the Year(14)

Day

Day of the Week|\Wednazdzy <
I Hour(15) |

Minute(1¢

e

( OSlsoft.
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Click Display 5 Time Columns:

Add Column x

Data Column Time Column Static Value

Select Time Column Options for | Local

Year (2016) TimeStamp (Local)
Day (24) Month (Local)
Day of the Week (Friday) Month Name (Local)
Minute (38) Week of the Year (Local)
Second (41} Hour (Local)

€

Milliseconds (520)

UTC Seconds (15357467271.82)
UTC Milliseconds (1535146721620)
Ticks (636707435218200000)

Time Zone Offset (0)

Now that the time ranges and columns have been specified, click Next.

Transformer Loading 4 L PISCHODL\studentdl 4%

Back
Start Time End Time
01-Jun-17 ‘ ‘ 31-AUg17 g m
Manth Name \ieek of the Year Hour Substation |E
ne 22 D éAvenida Central T

Now we can choose what target to publish to. This depends on the platform used to
support front-end application, but for our purposes we’ll publish to a SQL Server.
Select SQL Server for the Target Configuration, Leave Run Once checked, and click
Publish:
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— Transformer

Select Data » Modify View > Publish

Target Configuration Summary

SAL Server v Shape and Matches

s There are 100+ Matching Instances

Run Mode Timeframe and Interval

« Your Start Time is 2017-06-01T00:00:00.0002

Run on a Schedule = Your End Time iz 2017-08-31T723:00:00.000Z
= Your Time Interval gets an interpolated measurement Every 1
hour

It will take a few minutes to publish the data.
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Lesson 4: Building the Distribution Network Reports

We will now spend some time configuring a Microsoft Power Bl report. The first step
is importing the data.

Importing Data into Power Bl

Now that the Transformer Loading table has been published, we will import the SQL table into
Power BI.

Approach:
Open Microsoft Power Bl and start a new report.

Select SQL Server in the Data Group.

Fil= Home Insert Medeling View Help

@ la B

Get  Excel PowerBl]l SQL |Enter Recent
data v datasets| Server | data sources v

Clipboard Data

Enter PISRVO01 as the server name and click OK.
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SQL Server database

Server (i
| pisRVO1| |

Database (optional)

Data Connectivity mode (i
® Import
DirectQuery

I» Advanced options

OK Cancel

If Prompted, Leave “use my current credentials” selected and click Connect:

SOL Server database x
Windows pisrv0T

Use your Windows credentials to access this database.

Database

Microsoft account Use alternate credentials

Back Connect Cancel

There may be a warning that the connection is not encrypted, this can be safely ignored, click
OK:
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Encryption Support

We were unable to connect to the data source using an encrypted
connection. To access this data source using an unencrypted
connection, click OK.

Expand the Plint database and Select the Transformer Loading table, click Load

o X
Navigator
P|  Transformer Loading &
Display Options = ) Id H ters TimeStamp Month Month Name ~ Weel
4 PISRVO1 [9] 1 Alzjuela 6/1/2017 12:00:00 AM 6 June ~
b FlectGeneration 2 Alzjuela 6/1/2017 1:00:00 AM 6 June
3 Alzjuela 6/1/2017 2:00:00 AM 6 June
b FIFD 4| Alzjuela 6/1/2017 3:00:00 AM 6 June
4 [ Plint[1] 5 Alzjusia 6/1/2017 4:00:00 AM & lune
¥ [ Transformer Leading 6 Alzjuela 6/1/2017 5:00:00 AM 6| June
b PlintegratorDB 7 Alzjuela 6/1/2017 6:00:00 AM & June
b PlintegratorLogs 2 Alzjuela 6/1/2017 7:00:00 AM 6 June
9 Alzjuela 6,/1/2017 B:00:00 AM 6 June
I PlintegratorStats 5
10 Alzjuela 6/1/2017 9:00:00 AM 6 June
b Plision 11| Mlajuela &/1/2017 10:00:00 AM &|lune
3 ReportServer 12 Alzjuela 6/1/2017 11:00:00 AM & June
[ ReportServerTempDB 13 Alajuela 6/1/2017 12:00:00 PM & June
14 Alzjuela 6/1/2017 1:00:00 PM 6 June
15 Alzjuela 6/1/2017 2:00:00 PM 6 June
16 Alzjuela 6/1/2017 3:00:00 PM 6 June
17 Alzjuela 6/1/2017 4:00:00 PM 6 June
18 Alzjuela 6/1/2017 5:00:00 PM 6 June
19 Alzjuela 6/1/2017 6:00:00 PM 6 June
20 Alzjuela 6/1/2017 7:00:00 PM 6 June
21 Alzjuela 6/1/2017 8:00:00 PM 6 June
6 The data in the preview has been truncated due to size limits. [¥]
< >
Select Related Tables Load Edit Cancel

Note that about 3.8 million rows have been imported. This exceeds the 1 million row limit in
Microsoft Excel.
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Building the Report Visuals

Now that the Transformer Loading table has been imported, the rest of the chapter will be a
walkthrough of configuring various report visuals.

In case there were mistakes or problems with the previous steps, a starter .pbix file
has been created with the raw data set already imported with columns that will match
the exercises exactly.

Open C:\Class\Part 1 - PI Integrator for BA\Starter File - Part 1 Distribution
Network.pbix and use this as a starting point for the remaining exercises. Work from
the previous exercises can be safely discarded.

Transformer Loading Analysis

Objectives:

e Configure a Hierarchy

e Configure a Hierarchy Slicer

¢ Configure a Measure to calculate service hours

e Configure a Group to create bins for different load ranges which can then be used for
highlighting and filtering

e Configure a Stacked Bar Chart to display the service hours spent in each Load Range
by circuit

e Configure a Table to show the top 20 transformers by average Loading

e Configure a Slicer to filter by Month

In the following steps, we will analyze transformer loading characteristics. The goal is to assess
the number of service hours spent in various high load conditions to better understand which
transformers are at risk of failing and also assess whether a given transformer should be
replaced with one that has a higher capacity.

f() OSlsoft. Page 37



Analyzing Pl System Data

Approach:

Configuring the Hierarchy

We will now create a hierarchy. In the Fields List, click the ellipses next to Headquarters and
select New hierarchy:

Fields ).
O search

~ B Transformer Load...

O Circuit
O Headguarters D
Check

I New hierarchy I

Mew measure

Within the fields list, drag and drop the Substation field on top of the new Headquarters
hierarchy:

Fields >
/O Search

~ E Transformer Load...

] Circuit
O Headquarters

Substanhqy
J I-ead&r...
0= Hour +
O=x id

O= Loading

O Maximum ..
OZ Month

O Month Name
O Phase

O Z PlintShapelD
O X PlntTSTicks
O = Rated KVA

O Secondary ...
] Single Tra_n5...
I O Substation I
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Repeat for Single Transformer, Circuit, Phase, and Secondary Transformer and reorder to

match the below if necessary.

A~ [1%= Headquarters...
Headquarters
Substation
Single Trans...
Circuit

Phase

O000O00o

Secondary T...

Downloading the Hierarchy Slicer

For this part, there is no need to visit the web site, sign up, or download the file. We have
downloaded the file for use in class so that students do not need to sign up!

The Hierarchy Slicer is a custom visual that can be used to filter reports and mimic the Pl AF

hierarchy. This is similar to the PI TreeView from Pl WebParts.

Most custom visuals can be found on Microsoft AppSource. We will briefly go through the

procedure of how one would normally obtain a custom visual.

Search for a custom visual on Google or within AppSource and you'll arrive at a page like this:

https://appsource.microsoft.com/en-us/product/power-bi-visuals/WA104380820?tab=0Overview

At which point you would click Get It Now, sign in using your work or school account, and

download the .pbiviz file.

B® Microsoft Cloud Mobility Productivity
AppSource Apps Consulting services List on AppSource
HierarchySlicer

HierarchysSlicer

= ] -
e ] -
m Overview

_ 2

% % % (26)
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Importing and Configuring the Hierarchy Slicer

Now it’s time to import the custom visual. Open Power Bl, click the ellipses within the

Visualization Pane, and select Import from file:

Visualizations >
e

L L S | ]

5 o B

Import from AppSource

Fields >
O search

~ B Transformer Loading

O Circuit
O Headquarters

s [1% Headquarters...

dquarters
I Import from file Gtation
Values
A le Trans...
Add data field Remove a visual ]
it

Restore default visuals

Navigate to C:\Class\Part 1 - Pl Integrator for BA\Power Bl Custom Visuals and select the

HierarchySlicer file.

4 Downloads

T -

40
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Analyzing Pl System Data

We should now see the Hierarchy Slicer in the list of available visuals:

Visualizations >

Mimic PI AF Hierarchy — Hierarchy Slicer

This exercise requires the Hierarchy Slicer custom visual be imported and assumes the

Hierarchy has been configured.

We will use a Hierarchy Slicer to leverage the existing Pl AF hierarchy for filtering. Add a
Hierarchy Slicer by clicking the icon:

Visualizations >

b il b

wf [T]

f{ OSlsoft.
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Drag and drop the Hierarchy to the visual fields:

E @ = :1'-”4 Headquarter...
o Headquarters
_ « Substation

? @ o Single Trans...

Fields + Circuit
Headquarters Hierarchy » X - Phase

Headquarters B o Secondary T...

Substation B E'=Heur

Single Transformer x

Circguit * 0= d

Dhase = = Loading

Secondary Transformer X O = Maximum KVA

Experiment with the Hierarchy Slicer for a bit by drilling down through the levels. Note that
checking a box for a parent will also include the children. This is a great way to visualize how
filtering works in Power BI.
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Change the Title of the Hierarchy Slicer to Network in the formatting options. Change the color

and increase the text size.

Service Hours

O search
~ Title On —@
Title text
MNetwork
Word wrap
off O—

Font color

[m-]

Background color

O~

Now we’ll configure a Measure to calculate service hours. Each row in the data set represents 1
hour, so we can simply count the number of rows that have been filtered through user selection.

This should make a bit more sense when it all comes together.

Right click ANY of the fields from the Fields list and select New measure:

X Hour

Check

Mew hierarchy

Add to hierarchy

Mew measure

Mew column

Mew guick measure

f{ OSlsoft.
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Enter the below formula into the configuration box and hit Enter or click the Checkmark:

= Starter File - Part

File Home Insert Modeling View Help Format Data / Dri Table tools N
&) Name Service Hours "’% Whole number - E Data category | Uncategorized -
@ $-% 238 o :

Structure Formatting Properties

l e 1 Service Hours = CALCULATE(COUNT('Transformer Loading'[Loading])[)

The raw text is given below for convenience.

Service Hours = CALCULATE(COUNT('Transformer Loading'[Loading]))

From a configuration perspective, Measures and Calculated Columns are configured similarly
so the distinction may not be obvious.

Measures and calculated columns both use DAX expressions. The difference is the context of
evaluation. A measure is evaluated on the fly using a subset of data, whereas a calculated
column is pre-calculated at the row level within the table to which it belongs. A simple way to put
it is that Measures take into account the filtering that has been set by the end user of the report
(the stuff they’ve clicked on), while calculated columns are computed row by row and are not
influenced by the report filtering.

Loading Groups

Different ranges for Loading will be grouped into bins representing different Load Ranges. It is
normal for transformers to be operating at Loads higher than 100% of their rating, but loads in
the range of 125% and higher are potentially cause for concern. In order to calculate service
hours in the different Load Ranges, a group must be configured in the data set for filtering and
counting by the Service Hours Measure.

Right click on Loading and select New group.

I ] E Loading I

Check

Mew hierarchy

Add to hierarchy »
Mew measure

MNew column

MNew guick measure
Rename

Delete

Hide

View hidden
Unhide all
Collapse all

Expand all
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Change the name to Loading (25%) and set the bin size to 25, then click OK.

X
—
Groups
Name I Loading (25%) I Field Loading
Group type | Bin ¥ | Minvalue 0
Bin Type Size of bins ¥ | Maxvalue | 2993
Binning splits numeric or date/time data into equally sized groups. The default bin size is calculated based on your data.

Bin size IZS I

Reset to default

Loading by Circuit — Stacked Bar Chart

Now we can begin to configure the report. Click some empty space and then click the
Stacked Bar Chart icon:

Visualizations >
Elu = i = o
J b Ly

i -
i) —_

With the Stacked Bar Chart selected, drag and drop Fields from the data set into the field
configuration boxes. Use Circuit for the Axis, Loading (25%) for the Legend, and Service
Hours for the Value:

y
If
]
{

OSlsoft. Page 45
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r

Loading (25%) @0 @25 @5

sSR!

s B~ B Transformer Loadi...

E= E O Headguarters
- ® ~ % Headquarers...
00 @225 @250
T [0 Headquarters
1 O  Substation
O Single Trans...
i3 O Circuit
Circuit v X O  Phase
! O  Secondary T..
e 0% Hour
Loading (25%) v X 0= 14
= Load
Value o oacing
Service H x
S L 0% Madmum KVA
Toottips O Month
0.4M 08M
A Add dats fields here O Month Name
O  Phase

Drill through

Cross-report
off O—

Keep all filters

X PlintShapelD
O = PlintTSTicks
X Rated KVA

]

9 B Service Hours

Secondary Tr..

Next we will apply some formatting and filters to make the data set more manageable. We'll
change the color scheme and only show Loadings greater than 100%, since loads in the normal

range are not of interest to us.

Expand the Filters Pane:

Visualizations >
JEusmsmn
o b e bl e
gl L

Filter for Loading greater than 100%. Be sure to click Apply Filter:
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% Filters I
P search

Filters on this visual
Circuit
is (All)
Loading (25%) e.
is (Al o
Filter type @
Advanced filtering v

Show items when the value:

is greater than v

100

®and  Oor

Next go to the Visualization Options and sort by Service Hours (done by default in this version

of Power BI):

r ; ? Eﬂ E I amdli;me (MIE0Y LFI '
D, Export data -

Loading (25%) @125 @150 @175 9200 @225 @250 @275
™ N Show as a table

Universt=d
v
que San Jose l Spotlight Auxis
Angets sxsiics | |

Remaove

i X\

P 13 Sortdescending  fENEE 1
i Colegio Cientinice. [ H 1% Sort ascending v
Musac de los Ninos _| - o -
Turistico Montazumo _ I sort b}r ' Circuit
Escuela Joagquin _ Service Hours
Cementerios - @ And O Cr | | [

@ OSlsoft. Page 47



Analyzing Pl System Data

Next change the color scheme. With the Visualization selected, click the Format Icon in the
Visualization Pane and adjust the colors to better convey the severity of the loading levels.

EHE

)3 Search

. Data colors

125.00
B -

150,00
-

175.00
-

200.00
O~

22500
D -

250.00
M~

275.00
m -

The stacked bar chart should now look something like this:

Loading {25%) 125 150 @175 @200 @225 @250 275

Service Hours and Average Load by Transformer — Table

The next visual we will add is a basic table showing the Transformer Name, Phase, Service
Hours, and Average Load. We will then filter the table to show only the top 10 transformers by
average load. This will give us a quick indicator of which Transformers are consistently
overloaded.

48



Analyzing Pl System Data

Click some blank space on the canvas to deselect any visuals, otherwise you will
accidentally convert the Stacked Bar Chart to a Table.

Create a Table:

Visualizations p.

= bl E
b ks bl Usl Hd
[l fe B O H
S 3 o E] =

.
I
L

!
LS

14
I
1

Drag and drop the Secondary Transformer, Phase, Service Hours, and Loading Fields into
the Values section:

Visualizations > Fields >
= EHE B [0 e
b b e e U s
|l [ «B £ E -~ B Transformer Loadi...
S i G El & O  Circuit
'_Y E B |i. O Headquarters
@ ~ % Headguarters...
Sa= X Hour
- Oz id

T @
Values OiB| Loading (25%)
Secondary Transformer ~ % UX Maximum KVA
Phase X U= Month
Service Hours R 4 = [ Tt e

Loading v

O X PlintShapelD

Drill through = PlntTSTicks
0= Rated KVA

Cross-report

Off O—

4 Secondary Tr...

“ B Service Hours
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Change the Loading Value to summarize by Average:

Average of Loading >-<

Remove fisld

Rename
Mawe »
. Conditicnal formatting »

- - .
LR a L Ll -

b

Wiz

Don't summarize

Sum

+/ Average

Change the Visual Level Filters to Show the Top 20 Transformers by Loading.

S Filters @ » Visualizations >  Fields 5

il E Uy

Ii |.H. £ search
21
BT ks

P search

e

Filters on this visual E -~ B Transformer Loadi...

av

.||
[
7 <
O E M

Average of Loading = I ] Circuit
is (All) h 4 E R Py 5 [ Headquarters

L@ ~ % Headquarters...
Phase
is (All = 0= Hour

Oz ud

Secondary Transformer D I BZ Loading I
is (All) —

Values [Jif} Loading (25%
Filter type (0 .
I E— m I Secondary Transform UZ Maximum KVA

op

Phase e X Manth
Show items:

Ferias v X O Maonth Name
Top v |20 %

age of Loading K FHaEE

By value [JZ PlintShapelD

Aclell Bt EQ&:!{HT = Drill th rough [JX PlIntTSTicks
. [JZ Rated KVA

=]
'

filter Cross-report
i Secondary Tr...
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Change to summarize Loading as Average, then be sure to click Apply filter.

S
By value
Loading EX e
s
/’ Average
Apply filter at Minimum
the end Masirmum

Filtering by Month — Slicer

We’'ll now add a basic Slicer to filter by Month. Click some blank space and then add a Slicer:

Visualizations p

Drag Month Name to the field list.

Go into the formatting options and change the orientation to horizontal to change the look of
the Slicer.
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il K

L search

A (General
Outline color

B ~

Cutline weight

1 >

Crientation

Horizontal R

Reposition & Resize the slicer so all months are in a single row. Reposition & Resize the
table and stacked bar chart:

Network
Headguarters

*0 Algjuelz Sacondary Transformer  Phass Senvice Hours  Average of Loading
= Ca"'-ag_o Loading (25%) @125 © 150 @175 @200 @225 @250 @275 PT_XYZ0063 ¥ Phase 2208 :FE]
* O Heredia PT_XYZO0ES ¥ Phase 2208 20
* O San Jeronimo Universidacl - | PTXYZO0T1 ¥ Phase 2208 sz
+ O san Jose n PT_XYZ0096 ¥ Phase 2208 11608
] T_XYZON08 ¥ Phase 2208 13050
1 PTXYZ0I25 X Phase 2208 8292
PTXYZO0I9S ¥ Phase 2208 8018
PT_XYZ0210 X Phase 2208 7063
I PT_XYZ0254 X Phase 2208 8108
— PTXYZI3TT Z Phase 2208 LFAY
. PTRYZOAT0 2208 9254
Cementesios [ PT_XYZI43E 2208 3124
Paszo Coion [l PT_XYZ0566 2208 95,66
Escusla Platanares PT_XYZD5ET 2z08 7053
Averids 36 PT_XYZ0589 2208 #1463
S PLtvzn6c8 220 e
L] 500 1000 1500 2000 2500 FTAvIne 208 éran
PT_XYZ0824 2208 103.06
DT ¥¥7NG11 ¥ Dhas; 2208 12220
Total 24160 92.26

F = v B -1

Month Mame
] 1
August July June
L - -
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To put the Months in chronological order, we will sort the Month Name column in the data set by
the Month column where the months are numbered. Go to the Data View and click one of the
fields to make the data show up:

Starter File - Part 1 Distribution Network - Power Bl Desktop

File Home Help Table tools Column tools
E @ Transform data ~ ?Ij Quick measure pq Manage roles [IIT]
| E@ G? D% [&) = [% Refresh New FH New column )a View as Publi/]s\h
data v [ﬁ measure @ New table
Clipboard Data Queries Relationships Calculstions Security Shars B
w X v Fields >
Id || Headguarters |~ TimeStamp - | Month |*| Month Mame |~ | Week of the Year |~ | Hour |~ | Substation |~ | Sing
2 515497  Heredia 7/2/2017 12:00:00 AM 7 luly 27 0 | 5an Pablo T~ | O search :
515488  Heredia 7/2/2017 1:00:00 AM 7 uly 27 1|5an Pablo T
ﬁg 5154588 Heredia 7/2/2017 2:00:00 AM 7 July 27 Z | 5an Pablo i~ B Transformer Load...
813500 | Heredia 7/2/2017 3:00:0) Initially this will be blank, click one of 22 izl e I Circuit I
815501  Heredia 7/2/2017 2:00:0 the fields and the data will show up 27 4| 5an Pablo T
815502 Herzdiz 7/2/2017 5:00:00 AM 7 uly 27 5 | 5an Pablo Ti Headquarters
515503 Heradia 7/2/2017 6:00:00 AM 7| luly 27 £ San Pablo T 4 % Headquarters..
815504 | Heradia 7/2/2017 7:00:00 AM 7| July 27 7 | 5an Pablo i Headquarters
815505 | Heredia 7/2/2017 8:00:00 AM 7| July 27 & | 5an Pablo Ti Substation
815506  Heredia 7/2/2017 9:00:00 AM 7 July 27 58 5an Pablo Ti Single Transfaor...
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Select the Month Name column, open the Column Tools Ribbon, and Sort by Column ->
Month:

Starter File - Part 1 Distribution Network - Powe:

File Home Help Table tools

c

@ MName Month Mame 5%‘ - z Summarization | Don't summarize v %

l"‘,}; Data type | Text v ‘1\ % - E Data category | Uncategorized C:r:jnn_ll:_,l{ grc?j[iv .

Structure Formatting Properties Month Name R

m KX
Id E Headguarters B TimeStamp B Month Week of the Year B Hour B Substation |: et

@ 515497 Heredia 7272017 12:00:00 AM 7| uly 27 0 | San Pablo Headquarters o
515495 | Heredia 7/2/2017 1:00:00 AM 7| July 27 1| San Pablo 5

EE 5154585 | Heredia 7/2/2017 2:00:00 AM 7 uly 27 2 | 5an Pablo ke 5
815500 | Heredia 7/2/2017 3:00:00 AM 7 luly 27 3| 5an Pablo D 5
15501 | Heredia 7/2/2017 4:00:00 AM 7 uly 27 4 | 5an Pablo i 5
£15502 | Heredia 7/2/2017 5:00:00 AM 7 luly 27 5| 5an Pablo B 5
815503 | Heredia 7/2/2017 6:00:00 AM 7 uly 27 & | 5an Pablo Loading (25%) 5
515504 | Heredia 7/2/2017 7:00:00 AM 7 luly 27 7| 5an Pablo 5
815505 Herediz 7/2/2017 8:00:00 AM 7 uly 27 5|sanpabip | Mavdmum KVA .
815506 | Heredia 7/2/2017 2:00:00 AM 7 July 27 5 5an Pablo Meonth i
RT1E8N7T | Haradiz TN T 100NN AR RN ITT 7 1N | €am Dahin

The report should now look something like this:

Network Zecondary Transformer  Shass ours  Average of Loading
Headquarters Loading (25%) @125 © 150 @175 PT_XYZ00G3 ¥ Phase 2208 TE3
+ O Alzjuela PT_XYZ0065 ¥ Phase 2208 7201
4= go universidad | PT_XYZ0OTY ¥ Dhaze 2208 9568
+ O Heredia P ] FT_XYZDD96 X Phase 2208 11639
+ O san Jeronimo ] FT_XYZO108 X Phaze 2208 13050
» O San Jose X Phase 2208 2252
¥ Phase 2208 2012
X Phase 2208 7963
X Phaze 2208 2108
Z Phase 2208 171
Z Phase 2208 0254
Z Phase 2208 8124
9 ¥ Phase 2208 9666
PT_XYZ0587 ¥ Phase 2208 7853
FT_XYZD589 X Phase 2208 8163
PT_XYZD608 X Phase 2208 7636
- o0 - PT_XYZ0644 X Phaze 2208 a780
PT_XYZ0B24 Z Phase 2208 10306
FT_XYZ0S11 X Phaze 2208 12220
PTXYZ1470 X Phase 2208 8337
Tatal ane0 9226
Manth Mame
June July August
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Sort the table by Average of Loading:

D Add data fields here

o= Hours  Awverage of Loading B Export data ﬁ:. [ﬂ]
e TR E‘p Show as a table
2208 7201 . a
2208 azga X Remove =
2208 116.93 . ;
. == 0(3 Automatically find clusters = ?
2208 130,50 bz
2208 geoa | =0 Spotlight 000000 | e
2208 a0.1a Values
2308 ToE3
2208 2108 Add data fields here
2208 171
2208 9754 I Sort by r I Secondary Transformer
'ji‘ &l Phass
2208 96.68
2308 7O53 Service Hours
2208 3163 =
Ere —— I Average of Loading I

Click the bars on the Loading by Circuit chart and the Month slicer buttons and note how
the service hours and transformers for that load range update on the table.

We will save formatting until the end in case we need to save time, but feel free to adjust the
formatting and add a title.

Linking to PI Vision

We have a PI Vision display for Transformers that we can link to from this report. We will utilize
PI1 Vision URL Parameters to set the same Transformer in the PI Vision display that the user
clicks on in the Power Bl report. The URL parameters reference guide can be found in the PI

Live Library.

From within the client virtual machine, Navigate to:
https://pisrv01.pischool.int/PlVision/#/Displays/2/TransformerTrends

Take the above URL and append the following string to it in a text editor, then paste the URL
into Chrome:

?Asset=\\PISRVO01\Distribution Network\Secondary Transformers\PT_XYZ0046
Transformer PT_XYZ0046 should be the selected Asset in the TransformerTrends display.
Note that the ?Asset parameter denotes the path to the Asset in the Pl AF hierarchy.

Once that is working, configure a Calculated Column to concatenate the URL with the
Transformer asset path.

y
If
]
{
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Go to the Data Tab:

File Home Help Table tools Column tools
@ Name | Month Name % S Summarization | Don’
5 Data type | Text v - B Data category |Uncs
Structure Formatting Sropertie
(1T} X
Id |~ | Headguarters |~ TimeStamp - | Month |~ | Month Name |~ | Week of the Year |~ | |
E 815497 | Heredia 7/2/2017 12:00:00 AM 7 July 27
QE 515498 | Heredia 7/2/2017 1:00:00 AM 7 July 27
£15499 | Heredia 7/2/2017 2:00:00 AM 7 July 27
815500 | Heredia 7/2/2017 3:00:00 AM 7 July 27
515501 | Heredia 7/2/2017 4:00:00 AM 7 July 27
515502 | Heredia 7/2/2017 5:00:00 AM 7 July 27
£15503 | Heredia 7/2/2017 6:00:00 AM 7 July 27
815504 | Heredia 7/2/2017 7:00:00 AM 7 July 7
515505 | Heredia 7/2/2017 B:00:00 AM 7 July 27
E15506 | Hersdia 7/2/2017 3:00:00 AM 7 July 27
§15507 | Heredia 7/2/2017 10:00:00 AM 7 July 27
815508 | Heredia 7/2/2017 11:00:00 AM 7 July 7

Right click on the header of ANY column and select New column:

r Mﬂl‘l‘ﬂl 'II___ L S T PP S P S A | Hﬂur
Sort ascending

7| July

7 luly Sort descending
7 July Clear sort

7| luly Clear filter

7 | Clear all filters
7| July

7| July Copy

7 July Copy table
7 luly Mew measure
7 July Mew column
7

For the DAX formula, enter the following and hit enter or click the checkmark:

P1 Vision = "https://pisrv01l.pischool.int/PIVision/#/Displays/2/TransformerTrends" &
"?Asset=\\PISRVO01\Distribution Network\Secondary Transformers\" & 'Transformer
Loading'[Secondary Transformer]

Structure Formatting Properties Sort Groups Rel:

E RV I'l PI Vision = "https://pisrv@l.pischool.int/PIVision/#/Displays/2/TransformerTrends™ & ”?.Eass-et="\\PIS?\-‘@l"\Distr‘ibLi
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Next scroll all the way to the right and find the PI Vision column, then select it.

Go to the Column Tools ribbon, and change the Data Category to Web URL.

Column tools

Formatting

srv@l.pischool. int/PIVision/#/Displays/2/

Z Summiarization | Don't summarize

. B Data category | TEETENDER)

Uncategorized

Pn

Address

age Average |~ | Voltage Maximum | ~ | Voltage Mi

24125

12, 149993856454
11 199995545242
241875

11 225006103516
10.050003051758
19.850006103516
18.350006103516
i5.574536545242
15.824995545242
17.445995545242
17.049995545242
i7.074556545242

24125

242 149333896484
241.199936545242
241875

241 225006103516
240.050003051758
239 850006103516
239.350006103516
239 574336545242
238 824336545242
237.4439336545242
237.849336545242
237.074336545242

Place

242 14¢ tity

241.19¢  County

State or Province

241228

240.05(

239.85¢ Country
239.35(
238 57¢
238.82¢
237.44¢  longitude

Postal code

Continent

Latitude

w

237.84¢
237.07¢

Web URL

Now go back to the Report Tab and select the Table, then drag and drop the PI Vision field as

one of the table values

Values

T &

Secondary Transformer ~ X

Phase

Service Hours

R

R

Average of Loading R 4

Pl Vision

-

Mirill thranah

Oz d

# X Loading
O8] Loading (25%)
O X Maximum KVA

0= Month
O Maonth Name
v Phase

“ [ Pl Vision

[JE PlintShapelD
O Z PlntT5Ticks

The links are now displayed, and they work, but they are not pretty to look at. Luckily, Power BI
has a feature that addresses this.

OSlsoft.
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Go into the Formatting Options, scroll down to the Values section, and turn on the URL icon:

e

/O Search

.Ialues

Font color

Background color

-

Alternate font color

Alternate background col...

O~

Qutline
Mone
URL icon
On —@
Now the links look much cleaner:
¢ Transformer Phase Service Hours .&'-.-'era;s of Loading Pl Vision

BT, [ ¥ Phase 2208 =
BT_XYZ0O11 ¥ Phase 2208 12220 @
BT_XYZ037T Z Phase 2208 117.11 B
PT_XYZD096 ¥ Phase 2208 11698 @
PT_XYZDS84 I Phase 2208 m30s @
PT_XYZO566 ¥ Phase 2208 9666 @
PT_XYZOOT1 ¥ Phase 2208 gEEE @
PT_XYZ0410 I Phase 2208 9284 @

¥ Phase 2208 3720 @

¥ Phase 2208 8337 =
BTy ¥ Phase 2208 zzez @
PT_XYZD589 ¥ Phase 2208 8163 @
PT_XYZ0425 I Phase 2208 3124 ®
PT_XYZ0254 ¥ Phase 2208 o @
PT_XYZ0195 ¥ Phass 2208 an1E @
BT_XYZ0210 ¥ Phase 2208 7962 B
PT_XYZ058T ¥ Phaze 2208 7953 0 ®
PT_XYZD0G3 ¥ Phase 2208 7823 @
PT_XYZODGS ¥ Phass 2208 7801 =
PT_XYZO608 ¥ Phaze 2208 7636 @
Total 44160 92.26

Test the links to confirm that the PI Vision display is launched and the correct transformer is set.
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Lesson 5: Building the Fleet Generation Report

Now rather than a one-time export let’s build a report that pulls current data upon
refresh. To do so we'll configure a continuous Asset View that updates on a
schedule. We’'ll be using a different AF Database this time: Online Fleet Generation.

The Online Fleet Generation Database

We wish to analyze a number of KPIs for several generating units in a fictitious
power generation company. All data is simulated / random.

Open PI System Explorer and navigate to the Online Fleet Generation database.

The regular Fleet Generation database is used for the classroom version of this
course where PI SQL Client is part of the core material.

The Fleet Generation Sim database generates data for both the Fleet Generation
and Online Fleet Generation databases.
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Use for Online Course

FI'Big Tires Co., Fart 3 Training

aTest'ng

3312020 10:41:53 FM
10/14/2020 8:49:25 PM
6/17/2019 8:01:06 PM

10/14/2020 4:26:33 PM

Select Database x
il Mew Database X Delete Database 57 Database Properties (5] Edit Security
Asset server: ‘W PISRVO1 v| ﬁ Connec
Databases:
Fiter p - |
Mame Description Last Modified
aCcnﬁguratinn A& store for configuration data. 10142020 8:43:58 PM
@Distributiun Metwork Part 1 Training 430/2019 3:2H05PM
aFleet Generation Part 2 Training 10132020 4:26:48 PM
aFIeet Generation Sim Do not use - Do not delete - Feeds Fleet Generation 522019 4:01:26 PM
ﬁNuGreen PI BI Project Asset Model 4(30/2019 2:35:50 PM

Close

Browse the hierarchy, which is organized into Region, Station, and Unit.

5 Elements
= ( CENTRAL
E| albertsville
f i @ ceonl
L b (@ GACDZ
EI 5 Beryl Ridge
¢ e @ Bount
i e (§ BCUDZ
Bl & Carbondale
b @ TCBOL

G TCEOZ
@ TCEO3
& ToED4
i () TCBOS
b (1 TEBOS
H- () MORTH

[H- (F SOUTHEAST
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Most of the child elements are based on the generic Unit template.

Library

@ Online Fleet Generation
=] Templates
1~ E@) Element Templates

1 Transfer Templates
- @ Enumeration Sets
- ¢, Reference Types

Tables

7 Table Connections

[ Categories

EI Analysis Categories

- Attribute Categories

(&1 Element Categories

(=] Motification Rule Categories
Reference Type Categories
Table Categories

= Category: Status

Unit Status

UNIT
General Attribute Templates  ports  Analysis Templates  Motification Rule Templates
‘ Filter 5 - |
|f i € £ Name 4 Description Default Value ] ‘
= Category: <Mone:
{ 24 Carbon Emssions 0 gfih
% | ¢ Generating Efficency 0%
Generation Rate 0 §kWh
% | & Total Hourly Gross Generation 0 MWwhr
& Utilization 0%
Category: Demand
Demand oMW
=) Category: Hourly Generation
Gross Generation oMW
(E Net Generation omMw
=] Category: Identity
Hourly Capacity 0
=g Operator
shift 0
=g Shift Hours Mumber of Hours in the shift... |0 h
Technology 0

Those in the CENTRAL region are based on the Gas Turbine template, which is
derived from the UNIT template and has additional attributes.

Library Gas Turbine
@ Fleet Generation Starter General | Attribute Templates |Ports I Analysis Templates | Motification Rule Templates
= Templates
(@ Element Templates |
S (G UNIT Fiter
Gas Turbine |f i@ £ Name | Description Default Value
(& Steam Turbine
(@ REGION =] Categary: <Nones
£ STATION ' CE Exhaust Gas Temperature - #1 Probe iExhaust Gas Temper... |02C
Event Frame Termplates : i
+ Model Templates & Exhaust Gas Temperature - #2 Probe Exhaust Gas Temper.., |0°C
+1-- i Transfer Templates
e @) Enumeration Sets Gas Fuel Flow Gas Fuel Flow 0 U5 galfmin
%, Reference Types ) Gas Fuel Pressure Gas Fuel Pressure 0 bar
Tables
EJ Table Connections CE Gas Turbine Speed Gas Turbine Speed 0 rpm

D Categories
(€] Analysis Categories
Attribute Categories
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Gas Turbines have all the attributes from the Gas Turbine template, but also inherit

those from the UNIT Template:

Elements GAOOT
5 Elements General Chid Elements Attrbutes ports  Analyses Notification Rules  Version
Bl (3 CENTRAL
i B (@ Abertsvile
L @ Ghoo1 [ 2]
- ) GADD2 [# ]3¢ 8lname =/ value @ |
- () Beryl Ridge x

i [ (@ Carbondale

@ (§ NORTH

@ (G SOUTHEAST

(5, Element Searches

i & Element Attribute Search Results 1

a Template

s B | ¥ Total Hourly Gross Generation

] & Unit Status

afivh

92,987 MW

s B¢ | ¥ Generating Efficiency 90.909 %
m =1 Generation Rate 0.078 §/kih
= <7 Gross Generation 324,25 MW
@ 1 Hourly Capadty 550
= & Net Generation 294.25MW
m =1 Operator BSX
= & shift 3
@ =1 shift Hours 8h
Ll E1 Technology Natural Gas

335,75 MWhr

Active

s B& | gF Utlization / 61,045 %
B (F Template: Gas Turbine
m &7 Exhaust Gas Temperature - ... |33.313 °C
] 7 Exhaust Gas Temperature - ... |32.956 °C
] & Gas Fuel Flow 68,304 US gal fmin
) ¥ Gas Fuel Pressure 41.786 bar
] &7 Gas Turbine Speed 56.658 rpm

Preparing and Importing the Tables

For the report, we are going to separate the time-series data from the static data and configure

table relationships to join the data sets together. Technically, we could design the Asset View
such that the result set is a single table. However, in real life not all of the data is always in PI
and several data sources must be joined together. A table with one row per unit will also be
required for the Final Challenge in order to join Event Frames and geospatial information.
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Activity — Publish Unit Specifications (static data) Table

Objective:

o Publish an Asset View containing static attribute data

Approach:

Open Google Chrome and Navigate to the PI Integrator for BA Web Ul at
https://pisrv01.pischool.int:444

Click Create Asset View and name it Unit Specifications, click Create View:

@ Advanced Edition X +

&« > C @ pisrv01.pischool.int:444

Create New Asset View

Asset View Name

Unit Specifications|

Click Create a New Shape

Create a Maw Shape
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Select Online Fleet Generation as the AF Database, then drill down to GAOOL1.

Select Data > Modify View > Publish

I$I Source Assets b
Server PISRVO1 M
Database Online Fleet Generation < v

(D) Assets

4 [ CENTRAL

4 [ Albertsville

| GAOO1

) GA0D2
» [7) Beryl Ridge
» [ Carbondale
» () NORTH

» Q) SOUTHEAST

The static attributes are: Carbon Emissions, Generation Rate, Hourly Capacity, Operator,
Shift Hours, and Technology. Drag them to the shape configuration:

ISEI Search Shape

T Asset Shape

4 [ GAO001 &S X
Carbon Emissions & x
Generation Rate & x
Hourly Capacity & x
=] Operator & R
Shift Hours S x
=] Technology &S x
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Edit the shape. Uncheck the box next to Asset Name and match on the UNIT

template:

Edit Filters

[[]Asset Name

GAOO1

Asgset Template [ Search Derived Templates

UNIT

Add a filter to also include Gas Turbines:

Edit Filters

[[] Asset Name

GADOT

Aszset Template [ Search Derived Templates

UNIT

[ Asset Category

(+) Add Filter
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Uncheck the box next to Asset Name and match on the Gas Turbine template then

Save:

Edit Filters X
Filter 1 >
Filter 2 w

[]Asset Name
GAOOT
Asset Template [] Search Derived Templates
Gas Turbine -
[ Asset Category
W
(=) Remove Filter
(+) Add Filter

Click Next.

Change the Start Time and End Time to * since we only want one row per unit and

click Apply. The preview may not be accurate (missing some units).

Start Time End Time

*

=
.

Click Next.
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Publish to the SQL Server Target (run once):

Select Data > Modify View > Publish

Target Configuration Summary
I SQL Server w Shape and Matches
|
e |
Run Mode
Timeframe and Interval
Run on a Schedule = Your Siart Time is *

» Your End Time is *

e Your Time Interval gets an interpolated measurement Every 1
minute

When publishing is finished, check the statistics to confirm that 30 rows were
published:

Overview Log Security View Configuration

Run History
Oct 14,2020 218710 PM 0.669 30 [ 8]
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Activity — Publish Unit Performance (dynamic data) Table

Objective:

e Publish an Asset View containing dynamic attribute data

Approach:

Create a new Asset View name Unit Performance.

Create a new shape. Navigate to GAOOL in the Online Fleet Generation database.

Drag Demand, Generating Efficiency, Gross Generation, Net Generation, Shift,

Total Hourly Gross Generation, Unit Status, and Utilization to the shape
configuration (exclude those attributes specific to Gas Turbines):

() Search Shape
T, Asset Shape

68
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& Met Generation
& shift
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& Utilization
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Edit the shape to match UNITs and Gas Turbines (add a second filter) as per the
previous exercise:

Filter 1 b

(] Asset Name

GADO1

M Asset Template [ Search Derived Templates

UNIT '
Filter 1 >
Filier 2 hd

[ Asset Mame

GAOOT

Asset Template ([C] Search Derived Templates

Gas Turbine w

There should be 30 matches. Click Next.
Change the Value Mode to sample every 1 hour and Save Changes:

Edit Value Mode x

@ Sampled Values

® Sample values every hours =

@ Interpolate @
(1 Exact @

(C Use Key Column | Demand "

Cancel | Save Changes
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Change the Start Time to *-7d and click Apply.

Start Time End Time
~ 2]
Click Next.

Select SQL Server as the Target. Run on an hourly schedule to keep the data
current. Click Publish:

Select Data > Modify View > Publish

Target Configuration Summary

S0L Server w Shape and Matches

s There are 30 Matching Instances

Run Mode Timeframe and Interval
O Run Once - Your Star Time is *-7d
@ Run on a Schedule [ : :x;'fir:::x:n:gem an interpolated measurement Every 1
First Run LT
:

When publishing is finished, check the Statistics to confirm that 5070 rows were
published:

Qverview Log Security View Configuration Statistics

Run History

Oct 14, 2020 3:05:40 PM 2.469 5070 [} 0

Total 1 2.469 5,070 0 0
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Activity — Import the Unit Specifications and Unit Performance Tables
Objective:

¢ Import the SQL Server tables created in the previous exercises
¢ Rename the ‘UNITGas Turbine’ columns

Approach:
Open a new Power BI report.

Import data from SQL Server:

File Home Insert Maodeling View Help

@ B3| B

Get  Ewcel PowerBl| SQL |Enter Recent
data « datasets | Server | data sources «

Clipboard Cata

Enter PISRVO01 as the server name and click OK.

SQL Server database

Server (i
| pisRVO1| |

Database (optional)

Data Connectivity mode
® Import
DirectQuery

I» Advanced options

[0]4 Cancel

( OSlsoft. Page 71



Analyzing Pl System Data

If Prompted, Leave “use my current credentials” selected and click Connect:

SQL Server database X

Windows pisrvOT1

Use your Windows credentials to access this database.

Database

Microsoft account Use alternate credentials

Back Connect Cancel

There may be a warning that the connection is not encrypted, this can be safely ignored, click
OK if prompted:

Encryption Support

We were unable to connect to the data source using an encrypted
connection. To access this data source using an unencrypted
connection, click OK.
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Expand the Plint database and Select the Unit Performance and Unit
Specifications tables, click Load:

Navigator

P Unit Specifications ™
Display Options ~ Dﬂ Id UNITGas Turbine TimeStamp Carbon Emissions Generat
4 PISRVO1 [9] 1 ALX¥D1 10/14/2020 2:18:05 PM 17 ~
N FlectGeneration 2 BAID2 10/14/2020 2:18:09 PM 7
3 CECO1 10/14/2020 2:18:08 PM 17
[ PIFD
4 MAMOL 10/14/2020 2:18:09 PM 970
4 Plint [4] 5 MAMOZ 10/14/2020 2:18:09 PM 970
O E Gas Turbine Temperature Anomaly & MAMO3 10/14/2020 2:18:09 PM 970
[ E3 Transformer Loading 7 MAMO4 10/14/2020 2:18:09 PM 970
¥ [0 Unit Performance 8 MNDO1 10/14/2020 2:18:09 PM 405
: — 9 MNDO2 10/14/2020 2:18:09 PM 405
¥ 2 Unit Specifications
10 PLTOL 10/14/2020 2:18:09 PM 17
> PllntegratorD8 11 pLTOZ 10/14/2020 2:18:09 PM 17
I PlintegratorLogs 12 POEO1 10/14/2020 2:18:09 PM 17
b PlintegratorStats 13 PQE02Z 10/14/2020 2:18:09 PM 405
b PlVision 14 PQE0D3 10/14/2020 2:18:09 PM 405
15 PQED4 10/14/2020 2:18:09 PM 405
= ReportServer
16 PTCOL 10/14/2020 2:18:08 PM 870
b B ReportServerTempDB 17 PTCO2 10/14/2020 2:18:09 PM 970
18 PTCO3 10/14/2020 2:18:09 PM 970
19 ZMNO1 10/14/2020 2:18:09 PM 970
20 ZMNO2 10/14/2020 2:18:09 PM 970
21 BCUD1 10/14/2020 2:18:09 PM 405
22 BCUD2 10/14/2020 2:18:09 PM 405
W
23 GAOD1 10/14/2020 2:18:09 PM 405
L 4 >

Select Related Tables || Load | | Transform Data | | Cancel |

Once the tables have loaded, right-click -> Rename the “UNITGas Turbine’
column to UNIT for both tables.

X Fields >

10 [~ [{UNITGas Turbine | ~ | TimeStamn [~ | Carbon Emissions [~ ] Generation Rate [~ ] Hourly Capacity [~] Operator [~] shiftHours [ Technology [~]  PuntTsTicks  [~] PiintshapeiD [-]
= 1 AX0L Sort sscending 17 o1z 500 €06 12 Wing 537352816830510000 0 P search
ey Sort descending 17 o1z 750 PRT 12 Wing 537352516830510000 0
3 CECO1 Cl 17 012 600 COG & | Wind 637382518890810000 [ / ~ BB Unit Performance
4| mavo1 570 003 500 BSK 12 coal 637352518890610000 o Rename inboth tables! | — o i pecications
5 MAM02 570 0034 700 BSK 12 Coal 537352516530510000 0
6 MAMO3 - 970 0034 700 BSX 12 Coal 637382818890810000 [ Z s ETEeD
7| MAMO4 Copy 570 0034 700 Bsx 12 coal 53735281680510000 0 T Genertion Rate
& MNDO1 Copy table 405 0.078 650 BSX 12 Natural Gas 637352818890810000 0 Z Hourly Capacity
9 MND02 New measure 405 0.078 550 BSX 12 NewralGas  537382818890510000 0 Id
10| PTOL Mew column 17 o1z 500 BSX 12| Wind 637352818890510000 [} Gt
11 PLTO2 17 012 550 BSX 12 Wind 637352818850810000 0
Refresh data Z PlintShapelD
12 poE0L 17 ) 500 co6 5 Wind 637352618890810000 0
Edit query X PlintTSTicks
13 PQE02 405 0.078 650 BSX 8 | Natural Gas 637382818890810000 0
14 ps0s 05 o078 500, sk 8 NotwralGes | 637352818530810000 0 T shitHous
15 pag0s Detete 05 007 550 BSK 5 NetursiGss | 63733251889010000 0 Technology
16 | PTCOL Hide in report view o70 0034 500 NOP 8 Coal 637382818830810000 0 b B TimeStamp
17, proo2 570 0034 500 NOP 5 Ceosl 637352618890810000 0 UNITGas Turbine
Unhide all
18 PTCO3 hide 970 0034 750 PEE 8 Coal 6373582818890810000 0
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Activity — Create Table Relationships

Objective:

o Delete the automatically created table relationship between Id columns.
e Create a relationship between UNIT columns.

Approach:

In Power BI, Go to the Relationships tab, and click on the line:

4 Unit Performance

Hl Demand
F Generating Efficiency
Fll Gross Generaticn
1 d
Ell Met Generation
A PlintShapelD
Fll PlintTSTicks
Fll Shift
B TimeStamp
FA Total Hourly Gross Gener...
El UNIT
Fll Unit Status Hll Carbon Emissions
Hll Utilization Fll Generation Rate
F Hourly Capacity
1 1d
Al Operator
1 PlintShapelD
FA PlintTSTicks
FH Shift Hours

4 Unit Specifications

F Technology
El TimeStamp
Al UNIT

74



Analyzing Pl System Data

This relationship was automatically detected by Power Bl and is purely coincidental.
The Id is simply the row number. Right-click -> Delete the relationship.

£ Unit Performance

Bl Demand

F Generating Efficiency
Fl Gross Generation

1 d

Fl Met Generation

Fl PlintShapelD

A PlintTSTicks

A Shift

A TimeStamp

F Total Hourly Gross Gener...
Fl UNIT

EHl Unit Status

Fl Utilization

Properties

1] Unit Specifications
H Carbon Emissions
F Generation Rate
E Hourly Capacity
id

El Operator

F PlintShapelD

Ell PlIntTSTicks

FA Shift Hours

E Technology

A TimeStamp

El UNIT

@) ostsott
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Form the correct relationship by dragging UNIT from one table to UNIT on the
other table. Recall UNITGas Turbine was renamed to UNIT for both tables in a
previous step.

£F Unit Performance

El Demand

[ Generating Efficiency

Ell Gross Generaticn

Ml Id

Fll Met Generation

1 PlintshapelD

A PlintTSTicks

A Shift

A TimeStamp

Ell Total Houry Gross Gener...
Ty e — 55 Unit Specifications
Bl Unit Status Ell Carbon Emissions
Bl Utilization Hll Generation Rate

Hl Operator

W 71 PlintShapelD
Fl PlintTSTicks
EH Shift Hours
Hl Technology
Al TimeStamp

Now the Unit Performance table can be filtered based on selections from the Unit
Specifications table, for example using a slicer to filter based on Operator.

Augmenting the Data using DAX

Next, we will add a few calculations to the Unit Performance table that will help
assess the total Emissions produced and the total cost of generation. We will also
add columns for the day of the week and sort the Weekday in Sunday -> Saturday
order.

DAX is a collection of functions, operators, and constants that can be used in a
formula, or expression, to calculate and return one or more values. Stated more
simply, DAX helps you create new information from data already in your model.

For more information, consult the Microsoft Documentation.
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Activity — Calculate the amount of CO2 produced every hour

Objective:

e Add a DAX formula Calculate the amount of CO2 produced every hour

Approach:
In Power Bl, navigate to the Data Tab and select the Unit Performance table.
Right-click any column and add a new column. Enter the following formula:

CO2 = 'Unit Performance’'[Total Hourly Gross Generation]*RELATED('Unit
Specifications'[Carbon Emissions]

W~ |1 €02 = 'Unit Performance’[Total Hourly Gross Generation]*RELATED('Unit Specifications’[Carbon Emissions]

Note that Total Hourly Gross Generation has units of MWh, and Carbon Emissions has units of
g/kWh. Grams/kWh is the same as Kilograms/MWh, and therefore the result will be in KG.

y
vf
]
{

| &
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Activity — Calculate the Generation Cost

Objective:

e Add the cost calculation column to your Unit Performance table

Approach:

e Add and additional column named Cost to the Unit Performance table with
the dollar cost per hour.

e Take note of the input units of measure. Cost should be in dollars. Therefore
Cost = Total Hourly Gross Generation (from the Unit Performance table) *
Generation Rate (from the Unit Specifications table) * 1000

Activity — Add Column for Day of the Week and sort

Objective:

¢ Add the day of the week to your Unit Performance table, also add a column
with the numerical day of the week and sort by this value

Approach:

¢ Add and additional column named Weekday which shows the day of the
week as a string using the FORMAT() function

¢ Add another column named Numday which gives the numerical day of the
week using the WEEKDAY () function

¢ Sort Weekday by Numday

Column tools
r =]
L . o
Z Summarization | Don't summarize v % {E = =]
= . Sort by Data Ml =
izl Data category |Uncategorized - ork oy = f—mag )
: = column ~ groups « relationships
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Configuring the Visualizations

Now we will add visuals to the report to convey useful information about the

generating units.

Activity — Build the Report

Objective: Build an interactive Report comparing KPIs for different generation
technologies and operators.

Unit  Averagecf  Awrageof
Generating  Lhiliztion
Efficizncy

DT 69,12 40.04

FIcot £4.31 2874

Rz 6309 54.15

BAD2 6200 4352

BCUO2 1.0 5663

MARD so.gz 53.35

N0 5939 6404

MARMDZ 5893 5132

MAMD 3 s8.70 43.11

TR 58,05 5340

GAD01 sa4 57.5%

T BOR 5780 5460

TCEOS 57.28 5609

FQETR 5.0 7132

AL 5713 LEE")

Frco2 5570 5346

FQE 5546 5871

T e02 5322 3557

R 5282 G644

TCE0E 5170 6043

T B0d 50.38 a1z

FQEDZ 4366 38.29

Frco3 ag.17 3210

FOED 481z 3305

BC LT 4787 43.16

MMEDT 4552 a7.60

MAMD4 4151 27.42

MHEO2 782 3251

CECO1 3534 26.35

GAOOZ 1516 7112

Totl 5258 aate

Operatar CO2and Cost by Technalogy
Wind
BSX CoG MNOR FEE PRT
Technology Matural Bas
Ceal
Coal Matural Gas Wind
Syverage of Costby Technology and Operator
Operator @ESX @COG @MOP O PEE @PRT
R
Wind
Naturalzas %
Coa|
oK SK 10K 15K 20K 25K 30K 3K 40K 45K

Total Hourly Gross Generation by Weekday and Technology

Technology @Cce| @MatumlGas @Wind
150K

00K
) l l
oK
sun Mon

wed Thu
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Approach:
¢ Add a Table showing Average Generating Efficiency and Average Utilization
by Unit
Unit Puerage of fuerage of
Generating Utiliza tion
Eff iciency

ko 6912 40.04
PTCOA 6431 28.74
ATz 63.09 6415
BAIDZ G200 43,52
BC UOz2 61.00 BG83
Tl AhA0 ] Eo.g2 £3.35
i e Q.39 G404
MO 2 5393 £1.32
Ml AAO 2 £g.7a 459,11
TC BOA E2.05 E3.40
A0 Ea0d Er.ma
TC BOG Eran E4.20
TC BOS Lr.xa 609
FoEOZ Er.20 71.32
ALx0A E7.A3 G254
PTCOZ B0 346
PO B B4R 1=Rr
TCBOZ 53.23 EL-RT)
AL Lz2a2 G644
TC BOZ E1.70 60,43
TC B4 E0.32 41,3
FoEOZ 42,66 8.0
PTCOZ 4817 32,40
PZEOT 4812 33.05
BC U1 A7 5T 4316
MO 4B 52 47,60
il AhAC 41.51 2749
MWMOOZ 3782 3251
CECOH 3634 26.35
A 1516 i A
okl L2208 49199

e Add a Pie Chart showing how the C02 emissions from each generation
technology contribute to the whole. Add a Tooltip that shows the Cost when

the user hovers over the Pie Chart
r = ] |

Wind

FRT

I Matural Bas
Cral
Technol

80



Analyzing Pl System Data

Add a Clustered Column Chart showing the Sum of Total Hourly Gross
Generation with Technology as the Legend and Weekday as the Axis

Total Hourly Gross Generation by Weekday and Technology

Technology @Coal @HatumlGas @wind
150K

100K
0K
Sun hon Tue Wed Thu Fri Sat

Add a Clustered Bar Chart showing the Average Hourly Cost with Operator
as the Legend and Technology as the Axis.

Awerage of Costby Technology and Operator

Operatar @ESK @COG @HNOP O PEE @PRT

Wind

Matural Gas

Coa| e ——

oK EK 10K 15K 20K 25K 20K 5K 40K

Add Slicers for the Operator and Technology
Operator

BEx CoG MR PEE PRT
Technology

Coal Matural Gas i

Optionally improve the look and feel of the report through the use of
formatting. Bump up the font sizes, adjust column names and titles, etc.
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Solution — Build the Report

Solution file is in C:\Class\Part 2 - PI| OLEDB Enterprise\Solutions. There should be enough
screenshots in the exercise itself.

The only part that hasn’t been explicitly covered is adding the tooltip, which can be
accomplished by adding the Cost (summarize as Sum) from the Unit Performance table to the
Tooltips field:

< Visualizations >

r f— v B2 ..o
L ENEDER
- Eu;ngg
I nNewrals |§ bl ¥ II"‘:E'
t = w ,::::, .',,F__ D e
Coal '_'T M Fh R |i'

L]

-

Legend

Technology X

Details

Add data figlds here

Walues

co2 K
35K 40K 45K Tooltips

Cost LT 4
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Final Challenge: Fleet Generation Report with Event

Frames

The intent of the final challenge is to test your understanding of the course material
by going through the entire report development process on your own but first let’s get
some practice configuring Event Frame views.

Event frames for the last week may need to be backfilled depending on when the

virtual machines were deployed and how long they’ve been running for.

Activity — Backfill Event Frames in the Online Fleet Generation

database

Objective:

e Generate the Gas Turbine Temperature Anomaly and Inactivity Event Frames
for use in subsequent exercises.

Approach:

Open PI System Explorer and go to the Online Fleet Generation database.

In the Management area, add a new Search:

File Viev Go Tools Help
@ Database [ Query Date - @ @& | () Back

D \\PISRVOT\Online Fleet Generation - Pl System Explorer (Administrater)

H, Checkln ¥} « [2] Refresh

Management
Choose a type
@ Analyses
() Notification Rules

Analyses
0 total analyses selected (0 on this page) 1-1260f 126
[] staws @ B Element Hame

Operations

Enable | Disable selected analyses

0 o @} | SOUTHEAST\Wolverine Station Average Utlization Enabl le automatic recalculation for selected analyses
Analysis Searches D ﬁ @ SOUTHEAST\Vicksberg Average Utilization
; B ueue | Cancel backflling or recalculation for selected
O o @) SOUTHEAST\Stampton Average Utilization Eme‘s— 9
1 Al P | O & @ SOUTHEAST\Odtavia Average Utilization
& SOUTHEAST\Carter Average Utilization
Enabled - |2 2 o i ¢
O @ @] SOUTHEAST\Brick Canyon Average Utiization
Disabled 0 o @ NORTHiNew Bedford Average Utiization
I/ NORTH\Madison Average Utilization
g o @ NORTH:G : R g e Pending Operations
ol @ @ reenlawn verage Utiization R
(3 Elements 0O & @ NORTH\Ebbitt Average Utiization
T S— O o @) CENTRAL\Carbondale Average Utilization
9 L O @ @} CENTRAL\Beryl Ridge Average Utilization
 Libra -
2/ 0 @ @ CENTRAL\Albertsvile Average Utlization
wm Unit of Measure O @ | CENTRAL\Carbondale\TCEOS Gas Turbine Temperatu
48 Contacts O o | CENTRAL\Carbondale\TCBOS Gas Turbine Temperatu
[l r L1 cPMTR AL\ Carhandalal TrRNG ar Turhina Tamnarstu
[FEMamagement ]
[ Analyses
h

/
]
\

OSlsoft.
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Name it Gas Turbine Temperature Anomaly, then Add Criteria:

Search Mame: IEas Turbine Temperature Anomaly

Add Criteria *

Add criteria to search for specific items.

* Analy=es that match all of these criteria will be displayed,

Search on Name: Gas Turbine Temperature Anomaly and click OK:

Search Mame: |Gas Turbine Temperature Anomaly

Mame: Gas Turbine Temperature Anomaly

* Analysas that match all of these criteria will be displayed.

OK

Cancal

Select all analyses, click Queue, enter *-7d as the Start time, check the
acknowledgment box, and start the backfill:

Analyses
10 total analyses selected (10 on this page)

1-100f10 (<[>

Status @ B Element

) | CENTRAL\Carbondale\TCBOS
) |  CENTRAL\Carbondale\TCBOS
) | CENTRAL\Carbondale\TCBO4
o - CENTRAL\Carbondale\TCE03
(/] |+  CENTRAL\Carbondale\TCED2
[/] |+  CENTRAL\Carbondale\TCBO1
(] H CENTRAL\Beryl Ridge\BCU0Z
(] | CENTRAL\Beryl Ridge\BCUOL
(] | CENTRAL\Albertsville\GAQD1
(] | CENTRAL\Albertsville\GaO02
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Name Template
Gas Turbine Temperature Anomaly Gas Turbine Temperature Anomaly
Gas Turbine Temperature Anomaly Gas Turbine Temperature Anomaly
Gas Turbine Temperature Anomaly  Gas Turbine Temperature Anomaly
Gas Turbine Temperature Anomaly  Gas Turbine Temperature Anomaly
Gas Turbine Temperature Anomaly Gas Turbine Temperature Anomaly
Gas Turbine Temperature Anomaly Gas Turbine Temperature Anomaly
Gas Turbine Temperature Anomaly Gas Turbine Temperature Anomaly
Gas Turbine Temperature Anomaly Gas Turbine Temperature Anomaly
Gas Turbine Temperature Anomaly Gas Turbine Temperature Anomaly

Gas Turbine Temperature Anomaly Gas Turbine Temperature Anomaly

Backillng

A3

o

Enable | Disable selected analyses

Enable | Disable automatic recalculation for selected analyse:

Can:e\ backfilling or recalculation for selected

Start | *-7d ﬁ
na - -
What should we do with existing data?
® Leave existing data and fll in gaps
Permanently delete existing data and recalculate
a:knnmledga that my selection contains event
ame analyses. Event frames in the time range will
be permanently deleted. This will result i loss of

annotations and acknowledgements associated with
the event frames.




Analyzing Pl System Data

Repeat the above process for the Inactive Units Event Frame Analyses:

@ \\PISRVOT\Gnline Fleet Generation - Pl System Explorer (Administrator)

File View Go Tools Help

@ Database [=)QueryDate - O @ | Back () |H, Checkin ) « [2] Refresh

Choose a type

Management Analyses
30 total analyses selected (30 on this page)

1-300f30 <[>

® Analyses
Notfication Rules

Search Name: | Inactive Units

Name: inactve units x

= Analyses that match all o these criteria wil be:
displayed,

M

Status @ @

9
(]
]
]
9
9
]
9
9
(]
]
]
]
]
]
9
9
]
]
]
@

ITIITIITIIIIIIIIIIIIIIT

Element
SOUTHEAST Wicksberg\MAM02
SOUTHEAST Wicksberg|MAM(3
SOUTHEAST Wicksberg\MAMO4
SOUTHEAST\Wolverine Station| ALX01
SOUTHEAST Wicksberg\MAMU1
SOUTHEAST!\Stampton\MND02
SOUTHEAST|Stampton|MNDU1
SOUTHEAST\Octavia\ZMNOZ
SQUTHEAST \Octavia\ZMNOL
SOUTHEAST|Carter|BAJ02
SOUTHEASTIBrick Canyan|PLT02
SOUTHEAST\Brick Canyon|PLTOL
NORTH\New Bedford\POEDT
NORTH\Madison\CEC1
NORTH\Greenlawn|PTC03
NORTHGreenlawn|FTC02
NORTH\Greenlawn\PTCOL
NORTH\Ebbitt|PQEO4
NORTH\Ebbitt\FQEO3
NORTH\EbLitt\POEO2
CENTRAL\Carbondale\TCB06.

Name
Inactive Units
Inactive Units
Inactive Units
Inactive Units
Inactive Units
Inactive Units
Inactive Units
Inactive Units
Inactive Units
Inactive Units
Inactive Units
Inactive Units
Inactive Units
Inactive Units
Inactive Units
Inactive Units
Inactive Units
Inactive Units
Inactive Units
Inactive Units
Inactive Units

Template
Tnactive Units
Inactive Units
Inactive Units
Tnactive Units
Inactive Units
Inactive Units
Inactive Units
Inactive Units
Inactive Units
Inactive Units
Inactive Units
Tnactive Units
Inactive Units
Inactive Units
Inactive Units
Inactive Units
Inactive Units
Inactive Units
Inactive Units
Tnactive Units
Inactive Units

Badkiiling

3RO

Operations
Enable | Diszble selected analyses

Enable | Disable automatic recalculation for selected analyses

Quee | Cancel backiling or recalculation for selected
analyses

Start

End [*

What should we do with existing data?
existing data and fil in gaps

Permanently delete existing data and recalculate

1 acknowiledge that my selection contains event
frame analyses. Event frames in the time range vil
be permanently deleted. This will resultin loss of
annotations and acknowledgements associated with
the event frames.

@ osk
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Activity — Create an Event View with Pl Integrator for BA

Objective:

¢ Create an Event View with PI Integrator for BA

Approach:

We'll create an event view for Gas Turbine Temperature Anomaly events. Open
Chrome and navigate to https://pisrv01.pischool.int:444/.

Create an Event View:

My Views

+ Create Event View
Build a data view starting with
your event frame hierarchy

+ Create Asset View
Build = data view starting with

Build a streaming view with a Madify existing data view
your asset hierarchy

custom output shape

+ Create Streaming View & Modify View ¥ Remove View

Remove selected view
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Name the event view Gas Turbine Temperature Anomalies and click Create View:

Create New Event View x

Event View Name

Gas Turbine Temperature Anomalies|

Create a new Shape:

SelectData > Modify View > Publish Next

il Source Events ~ " Search Shape  Matches.
¥4 Event Shape

import & shape from an existing view or creste & new one

Point at the Online Fleet Generation database, since that's where the Event Frames
are:

Select Data » Modify View > Publish

"H Source Events |
Server PISRVO1 v
Database Online Fleet Generation S v

Enter Even Distribution Network

Fleet Generation
Event Frames As:

Fleet Generation Sim
» F4 Albertsville GAOOT|
NuGreen

-

k4 Albertsville GAQOT

-

F Albertsville GAODT] OMF

¥4 Albertsville GACD | Online Fleet Generation

4 Albertsville GAOD1| P1Big Tires Co.

-

-

v

"4 Albertsville GAOD1  Testing
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Recent Event Frames should show up in the preview. Everyone’s data is random,
so everyone’s preview will look different:

Select Data > Modify View > Publish

4 Source Events v "4 search Shape

Event Shape
Server PISRVO1 M b '
Database Fleet Generation =

‘ Y ‘ Enter Ev ors

Event Frames Assets
» "4 Albertsville GAOO1 Gas Turbine Temperature Anomaly 2020-03-31 17:46:50
» "4 Albertsville GAOO1 Gas Turbine Temperature Anomaly 2020-03-31 21:25:51
» "4 Albertsville GAQ01 Gas Turbine Temperature Anomaly 2020-03-31 22:59:25

» “4 Albertsville GAQ01 Gas Turbine Temperature Anomaly 2020-04-01 12:08:57
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You just need to find an event frame of the proper type in order to start building the
shape, but let’s look at the filtering options which will allow you to narrow down the
search.

Click the filter icon:

H Source Events v
Server PISRVO ’
Database Fleet Generation <o

|| Y | Enter Event name or string match pattern

Event Frames Assets

These settings allow filtering the preview and will help you find the event you'’re
looking for. On a production system there could be over a million Event Frames
spanning many different types.

‘ Y | Enter Event name or string match pattern ‘
@® Filter Events by Time >
%, Filter Events by Assets >
b Filter Events by Events >
More Options >

Filter Events by Time is pretty straightforward.

Filter Events by Asset allows you to filter by primary referenced Element (the
Element in AF whose Analysis generated the event). No need to set anything here,
this is just an example.

Asset Name

GADDT

Asset Template

Gas Turbine T

Gas Turbine
REGION
STATION
Steam Turbine
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Filter Events by Events allows you to filter by Event Frame name or Event Frame
Template. Select Gas Turbine Temperature Anomaly as the Event Template and
click Apply Filters to filter out the Inactivity Events:

Event Name

Enter Event name or string match pattern

Event Template

Gas Turbine Temperature Anomaly v

Clear All Filters [V ARTE]

And while we won'’t set anything, let’s take a look at More Options. Click the
guestion mark to see explanations for the Search Mode. Minimum Duration and
Maximum Duration are self-explanatory. All descendants applies to hierarchical
event frames, which we don’t have.

Database |, .- ~
Event Frame Search Options

. Enter Event 1 Includes all objects whose start time is -
Enter Event 1
within the specified range

End Inclusive
Includes all objects whose end time is within

Search Mcd the specified range

Inclusive
Overlapped Includes all objects whose start and end v

time are within the specified range

Minimum Duratii Overlapped
Includes all objects whose start and end
fone time overlap with the specified range

Maximum Duration

| none |

All descendants
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If you can’t find Gas Turbine Temperature Anomaly events, it’s possible that they
weren’t backfilled. Check to see if they exist in the Online Fleet Generation database
through Pl System Explorer and troubleshoot as necessary.

Once you see some events, you can start to configure the Shape. Click one of the
Events, then drag and drop all Attributes:

FH Source Events v " Search Shape

Event Shape
S PISRVO1 N 8 3
Database Fleet Generation c v

| Y | center Event name or string match pattern ‘ ;T::;Dp =Ll
Event Frames Assets
I » 4 Albertsville GAOQ1 Gas Turbine Temperature Anomaly 2020-03-31 17:46:50 ||
» "4 Albertsville GAOO1 Gas Turbine Temperature Anomaly 2020-03-31 21:25:51

v

P4 Albertsville GAOOT Gas Turbine Temperature Anomaly 2020-03-31 22:59:25

v

P4 Albertsville GAOO1 Gas Turbine Temperature Anomaly 2020-04-01 12:08:57

v

"4 Albertsville GAOO1 Gas Turbine Temperature Anomaly 2020-04-01 17:03:57

v

¥4 Albertsville GAOOT Gas Turbine Temperature Anomaly 2020-04-02 11:37:29

-

F4 Albertsville GAOO1 Gas Turbine Temperature Anomaly 2020-04-02 16:02:29

v

"4 Albertsville GAOO1 Gas Turbine Temperature Anomaly 2020-04-02 16:22:29

Show Mare

Attributes

Filter

& Deselect All

Duration

& Exhaust Gas Temperature - #1 Probe

4 Exhaust Gas Temperature - #2 Probe

& Gas Fuel Flow

4 Gas Fuel Pressure

- Gas Turbine Speed
Technology
4 Unit Status

ee|o|e|ec|o|e|e

Edit the Shape:

M Search Shape
HH Event Shape

4 b4 albertsville GAOO1 Gas Turbine Temperature Anomaly 2020-03-31 17:46:50
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Uncheck the box next to Event Frame Name and match Event Frames by Template

then Save.

Edit Filters

|_| Event Frame Name

Albertsville GAOD1 Gas Turbine Temperature Anomaly 2020-03-31 17:46:50

[# Event Frame Template

|| Search Derived Templates

Gas Turbine Temperature Anomaly

|| Event Frame Category

(+) Add Filter

Expand the Event Frame and drag and drop the Gas Turbine to the shape

configuration:

H Source Events

“ P Search Shape

Server

PISRVO1

¥ Event Shape

v

Database

Fleet Generation

~
=

4 i Gas Turbine Temperature Anomaly
v

Y

Enter Event name or string match pattern

Event Frameas Assets

E"& Albertsville GAOO1 Gas Turbine Temperature Anomaly 2020-03-31 17:46:50

| | @saom | —~

» Hd albertsville GAQO1 Gas Turbin:
» M albertsville GAOO1 Gas Turbine Temperature An

» Fi albertsville GAOO1 Gas Turbine Temperature Anomaly 2020-04-0

erature Anomaly 2020-03-31 21:25:51

020-03-31 22:59:25

» o Albertsville GAOOT Gas Turbine Temperature Anomaly 2020-04-01 17:03:57

» M4 Albertsville GAOO1 Gas Turbine Temperature Anomaly 2020-04-02 11:37:29

Edit the Gas Turbine object:

£ GAOO1
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Auto drop and place
£ 6A001
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S x
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Filter by Asset Template, click Save:

Edit Filters

Asset Mame

GAODT

Primary Reference Asset

# Asset Template Search Derived Templates
Gas Turbine v
| Aszet Category
v

(+) Add Filter

Cancel

You should see a bunch of matches. Go to the Next screen:
* @

@@ Advanced Edition x 4+
< C @ pisv01.pischoolint444/EventViewDesigner
= Gas Turbine Temperature Anomalies L PISCHOOL\student01
SelectData > Modify View > Publish Next
¥4 Source Events W "4 Search Shape / Matches
S - ] FdEventShape Found 100+ Matches
Database 4 "4 Gas Turbine Temperature Anomaly £ x » "4 Carbondale TCBO3 Gas Turbine Temperature Anomaly 2020-03-31 17:46:50
Fleet Generation s v
Duration a3 » ¥4 Carbondale TCBO6 Gas Turbine Temperature Anomaly 2020-03-31 17:46:50

‘ Y | enter event & Exhaust Gas Temperature - #1 Probe xR » "4 Carbondale TCBO4 Gas Turbine Temperature Anomaly 2020-03-31 17:46:50

& Exhaust Gas Temperature - #2 Probe a3 » "4 Carbondale TCBO2 Gas Turbine Temperature Anomaly 2020-03-31 17:46:50

Event Frames Assets
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Change the Event Frame Duration Data Content to Second otherwise it will be

displayed as a round number of hours.

Be sure to click Apply Changes.

|

e s L T T S

Iint Frame Durd

imeStam Juratio st Gas Temperature - #13t Gas Temperature -

3/31/202 13 141
3/31/202 12,906
3/31/202 8,620
3/31/202 8,385
3/31/202 5,719
3/31/202 5,719
3/31/202 5,719
4112020 25,767
3/31/202 5,719
3/31/202 9,900

3/31/202 5,014

Gas Turbine Temperature Anomalies

0

0
5.805
8.902
225
1.642
3.259
0.478
122
1.726
0

® Column Details

Name
Start Time End Time
Reset Name to Default
*7d |
Data Content -]
#2 as Fuel Flc 3as Fuel Pressure 3as Turbine Spee< Technd Second
2882 0 0 0 Natural G
-4.387 0 0 0 NEWEe Time Context
8613 22079 43.05 27.099 Natural G
13.892 7316 52721 61.381 Natural G
2544 24131 2308 23.216 y=were Data Type
5.068 24567 17.728 14.406 Natural G
5234 15775 10.359 29693 Natural G
-3.369 32191 9.443 14.006 Natural G _
2511 18.445 9685 20698 Natural G
062 14143 20213 19.272 Natural G _
-1.343 0 0 0 Natural G

Change the Start Time to *-7d and end time to *, click Apply, then move to the Next

Screen:

Start Time

End Time

Back Next

~7d

|

*

= T

Select SQL Server as the target and have it run on an hourly schedule to keep the
Event Frames current, then click Publish.

94

Select Data » Modify View > Publish

Target Configuration

Summary

| SAL Server

‘Shape and Matches

Run Mode

Run Once

® Run on a Schedule

First Run

|“"

Recur every I hours =

= There are 100+ Matching Instances
Timeframe and Interval

* Your Start Time is *-7d
s Your End Time is *

* Your Time Interval gets an interpolated measurement Every 1
minute
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Check the statistics to confirm that Rows were written:

+ Create Asset View
Build 2 data view starting with

+ Create Event View +
Build 2 data view starting with

Create Sireaming View
Build 2 streaming view witha

& Modify View
Modify existing data view

X Remove View
Remove selected view

your asset hisrarchy your event frame hierarchy custom outpur shape
Name Run Status Type Run Mode Start Time End Time Last Run Time

Distribution Network $a_. @ Published Asset Once 01-Jun-17 31-Aug-17 23:00:00 Apr 30, 2019 9:43:30 PM
Transformer Loading @ Published Asset Once 2017-06-01T00:00:00.0.... 2017-08-31T23:00:00.0... Apr 1, 2020 3:22:48 PM
Fas Turbine Temperatur... Scheduled Event Continuous =7d o Apr 7, 2020 7:55:11 PM |

Overview Log Security View Configuration
Run History Duration (seconds)
Apr7,2020 7:55:15 PM
ApI7,2020 755:15PM  5.75 0 0 57
104
a5
Total 1 575 225 ] 0 |
a0

| View Logs for Run

Download Selected Report

Reading from Pl

" Enable Full Reporting

Fitering & Calouisting

Witing fo MSSQL.

Optionally use SQL Server Management Studio to confirm that Event Frames were
written to the SQL Server table:

Object Explorer
Connect~ ¥ ¥ ¢+

/*=**=* Script for SelectTophRows command from SSMS

E=re—y

1 1@ PISRVOT (SOL Server 13.0.1601.5 - PISCHOOL\student01)
= 1 Databases
System Databases
Database Snapshots

@ FleetGeneration

[ESELECT TOP (1@@8) [Id]

,[Gas Turbine
,[Event Frame
,[Event Frame
,[Event Frame
L [TimeStamp]
. [buration]

Temperature Anomaly]
Start Time]

End Time]

ouration]

W PlintegratorDB

@ PlintegratorLogs

W PlintegratorStats

@ PIvision

@ ReportServer

@ ReportServerTempDB
Security

Server Objects

Replication

Full-Text index + [A001 Gas Tutbine Tempersture Anomaly .. 20200231 17:46:50.000

[CBU2 Gas Turbine Tempersture Anomaly...  2020-03-31 19:02:11.000
stretch > BCUD2 Gas Turbine Temperature Anomaly. . 2020-03-3119:02:11.000
Policies » [CBOS Gas Tubine Temperature Anomaly...  2020-03-31 18:46:37.000
Facets [CBU6 Gas Turbine Temperature Anomaly... 20200331 19:46:37.000

20200331 19:46:37.000
20200331 19:46:37.000
20200331 19:46:37.000
20200331 13:46:37.000

FCBO3 Gas Turbine Temperature Anomaly..
[CBO4 Gas Turbine Temperature Anomaly.
[CBO1 Gas Turbine Temperature: Anomaly.
CUIO1 Gas Tubine Temperaiure Anomaly.

Start PowerShell

Reports

202003-3121:21:56.000
2020-03-31 21:25:51.000
202003-3121:21:56.000
20200331 21:21:56.000
202003-3121:21:56.000
202003-3121:21:56.000
2020-04-07 02:56:04.000
202003-3121:21:56.000
202003-31 22:31:37.000

O N N N

& PIFD . [Exhaust Gas Temperature - #1 Probe]
& Plint L [Exhaust Gas Temperature - #2 Probe]
=] Tables ,[Gas Fuel Flow]
System Tables ,[Gas Fuel Pressure]
FileTables ,[Gas Turbine speed]
External Tables > [Technology]
fizzkdbo.Gas Turbin. funit ftatus]
B2 dbe.Transformer Loading New Teble... ;:i::l]
@ Views Design o
Extenal Resources Selectiopll 0 Rows) .[dbo] . [Gas Turbine Temperature Anomalies]
Synonyms Edit Top 200 Rows
& M Programmability Script Table as »
Service Broker s
Storage View D Temperature Anomaly Event Frame Stat Tme  Event Frame End Tme  Event Frame Duration  TimeStamp 3
B M Security e |A002 Gas Turbine Temperature Anomdly .. 2020-03-31 17:46:50.000  2020-03-3121:25:51.000 20200331 21:2551.000

2020:03-31 21:21:56.000
2020-03-31 21:25:51.000
2020-03-31 21:21:56.000
20200331 21:21:56.000
2020-03-31 21:21:56.000
2020-03-31 21:21:56.000
2020-04-D1 02:56:04.000
2020-03-31 21:21:56.000
2020-03-31 22:31:37.000

@ osk
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Activity — Build the Final Report
This is your chance to build a report from scratch using the concepts learned earlier
in the course. Let’s see if you can remember how to do everything!
Objectives:

¢ Incorporate downtime (Inactivity) events

¢ Determine the carbon footprint of each unit and display on a US map.
Approach:

e Create a new Sheet in the Fleet Generation Report (the imported tables will
be re-used)

e Geospatial information for all units in Fleet Generation is located in
C:\Class\Final Exercise\Unit Coordinates.xIsx. This data will need to be
imported into the data cube.

al | = |

Home raodeling Help
= Gk B 3
Q] rs

E@ Coapy
Paste ) Get | Recent  Enter Edit
Format Painter  |Data« | Sources = Data  Queries =
Clipboard Most Common

. ‘ Exicel e

e Use PI Integrator for BA to publish an Event View for Inactivity events
o You need a column to form the relationship between the Unit
Specifications table and the Inactivity Event Frames, it’'s probably
easiest to join on Unit Name (GAQOOQ1, etc).
o Configure a continuous Event View that updates hourly. The initial
publication should include the last 7 days

e Import the Inactivity events for the last 7 days using the above Event View

o Create the table relationships (should happen automatically if all columns are
named Units).
o Between the Unit Specifications table and the longitude/latitude table
o Between the Unit Specifications table and the Inactivity query results

o Insert a table showing the number of downtime events (Inactivity Event Frames) and
average duration of event frames for each unit. Add the Average Utilization to the same
table.

e Insert a map within the client to display the location of each of the units and the
associated total hourly carbon emissions.

e Configure the report in such a way that the Table relationships are tested. Use data from
multiple tables in the same Visual.
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e Customize the display to make it more user friendly by improving the formatting and
adding slicers.

¢ When configuring the Event View, the Data Context must be set to Second or else it will
round to the nearest whole hour (which will always be zero).

IO ERIE ® Column Details
Name
.
};ﬂﬁfmﬁes Start Time - = ame to Default
t-7d =4
Data Content
Event Frame Duratian Demand

GO0 142.12

GO0 272234

B0 175.188

B0 276 896

B0 231 862 Data Type

3000 265.04

300 183.634

300 183.162

300 182.241

300 254 444

GO0 208.43
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e Use the ordinary map, not the ESRI one. Drag and drop latitude and longitude from the
table that was imported from the Unit Coordinates.xIsx spreadsheet.

VISUALIZATIONS

Location

Add data fields here

Legend

Unit
Latitude
Latitude
Longitude

Longitude
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A sample of what the report could look like:

Gross Generation by Region (MWh)

Fleet Generation Report

Technology & v
s e, B e,
Operator ALX01 0.20 136 98.46
BSX coG NOP PEE PRT om BaJ02 0.21 158 69.34
1 . BCUO1 021 175 69.97
CO2 Emissions by Unit SOUTHEAST CENTRAL NORTH BCUO2 022 161 9946
Urit {BERT/ CECO1 020 163 30.98
L B i GAOO1 020 162 86.50
o802 " j GAO02 021 156 10.54
®8cU0t O MAMO1 021 171 73.97
Bcu02 : MAMO2 020 158 84.48
@cEco g A MAMO3 022 160 65,57
001 . MAMO4 021 146 39.12
MNDO1 021 164 40.76
ooron MNDO2 0.19 158 4894
AN PLTO1 020 161 106.83
@MaMo2 LU A PLTO2 022 160 113.27
MAMO3 POEO1 021 160 40.03
®MAMDA PQE02 020 165 58.66
it PQE03 020 157 11675
. PQE04 022 158 84.47
i JCalgary PTCO1 021 162 39,92
PTCO2 0.20 152 80.34
OFLTE PTCO3 0.20 163 4611
POEQT TCBO1 0.21 152 7853
POEO2 TCBO2 020 161 4151
@POED o : TCBO3 0.21 166 10341
[ Jeldv) Jarcodver O TCBM 0.22 154 60.18
®rTCol : TCBOS 020 154 91.09
> : ms i s s

ictoria 2 5

b Bing ) | @ FASHBRE, © 2018 Misresoft Corporation Terrs ZMN02 020 163 97.32

The above report can be found in C:\Class\Final Exercise\Solution
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