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1. PI System Basics 

1.1 What is a PI System? 

Objectives 

• Define the components of a PI System.  

• Draw a diagram of the architecture of a PI System. 

1.1.1 The PI System described 

The PI System collects, stores, and manages data from your plant or process. Your 
data sources connect to one or more PI Interface nodes. The PI Interface nodes 
collect data from your data sources and store into the PI Data Archive.  
Asset Framework (AF) organizes and enhances the data. Users consume the data 
by the use of a tool of the PI Visualization Suite (PVS) such as PI Vision. 

 

The following is a diagram of the components of a simple PI System: 
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1.1.2 Architecture of a Typical PI System 

Sometimes the architecture can be very simple. Some customers have as few as 
one or two PI Interfaces feeding data to a Data Archive from which the data can be 
consumed by various applications. The following is an example of a fully developed 
PI System, which includes most of the widely used OSIsoft products. 

 

 

 

In the diagram above, two PI Data Archive computers are shown to represent a PI 
Data Archive collective. A collective is a configuration of multiple servers that act 
as a logical PI Data Archive server in your PI System to provide high availability 
(HA), disaster recovery, load distribution, and increased scalability. A collective 
consists of one primary server and one or more secondary servers. 

Note: In computer security, a demilitarized zone, named after the military usage of the term and 
normally abbreviated to DMZ; also known as a Data Management Zone or Demarcation Zone or 
Perimeter Network, is a physical or logical subnetwork that contains and exposes an 
organization's external services to a larger, untrusted network, usually the Internet. The purpose 
of a DMZ is to add an additional layer of security to an organization's Local Area Network (LAN); 
an external attacker only has access to equipment in the DMZ, rather than the whole of the 
network. [Reference: http://en.wikipedia.org]  
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1.2 PI Points 

What is a PI Point? 

A PI Point (sometimes referred to as a PI Tag) is a unique storage point for time-series data 
in the PI Data Archive. It is a single point of measurement and has a value with a timestamp, 
such as a temperature of 31.2 oC on 31-Jan-2022 23:59:00.  

Some common PI Point attributes 

• Name: The name of the PI Point, which must be unique within the PI Data Archive.  

• Description: A free text field attached to a PI Point, often used to enter a human 
friendly description of the PI Point.  

• Point Type: This attributes defines the type of data that is stored in the PI Data 
Archive, e.g. float, integer, string, etc.  

• Point Source: This attribute commonly specifies which PI Interface is collecting the 
data for the PI Point.  

 

1.3 Time and the PI System 

Objectives 

• Define the time abbreviations in the PI System. 

• Define the time expressions in the PI System. 

• Introduction to Future Data. 

• Explain how the PI System handles times zones and daylight savings time 
(DST). 

 

You can use a special syntax, called PI System time, when specifying inputs for 
timestamps and time intervals. The PI System time uses specific abbreviations, 
which you combine to create time expressions.  
 

1.3.1 PI System Time Abbreviations 

When specifying a PI System time, you can use specific abbreviations that represent 
time units and reference times. 

 

Abbreviation Time-unit 

s second 

m minute 

h hour 

d day 

w week 

mo month 

y year 



PI System Basics 

 

Page 4 

 

 

To specify time units, you can specify the abbreviation, the full time unit, or the plural 
version of the time unit, such as s, second, or seconds. You must include a valid 
value with any time unit. If specifying seconds, minutes, or hours, you can specify a 
fractional value. You cannot specify fractional values for other time units. 

 

Abbreviation Full Reference-time 

*  Current time. 

t (or T) today 00:00:00 (midnight) of the current day 

y (or Y) yesterday 00:00:00 (midnight) of the previous day 

 

Abbreviation Full Reference-time 

sun Sunday 00:00:00 (midnight) on the most recent Sunday 

mon Monday 00:00:00 (midnight) on the most recent Monday 

tue Tuesday 00:00:00 (midnight) on the most recent Tuesday 

wed Wednesday 00:00:00 (midnight) on the most recent Wednesday 

thu Thursday 00:00:00 (midnight) on the most recent Thursday 

fri Friday 00:00:00 (midnight) on the most recent Friday 

sat Saturday 00:00:00 (midnight) on the most recent Saturday 
 

1.3.2 PI System Time Expressions 

The PI System time expressions can include a reference-time and a time offset, 
indicated by a direction (either + or -) and a time unit with a value. PI System time 
expressions might include: 

• Only a reference time, such as “y”  

• Only a time offset, such as “+3h”  

• A reference-time with a time offset, such as “y+3h”  

A reference-time can be a fixed time, such as “24-aug-2012 09:50:00”, or a valid 
reference-time abbreviation, such as “t”. 

You can only include one-time offset in an expression. Including multiple offsets can 
lead to unpredictable results. For example, the following time expressions are not 
valid: 
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1.3.3 Timestamp Specification 

To specify inputs for timestamps, you can enter time expressions that contain: 

Fixed times  

A fixed time always represents the same time, regardless of the field or the current 
time. 

Input Meaning 

23-aug-12 15:00:00 3:00 p.m. on August 23, 2012 

25-sep-12 00:00:00 (midnight) on September 25, 2012 

 

Reference-time Abbreviations  

A reference-time abbreviation represents a time relative to the current time.  

Input Meaning 

*  Current time (now) 

3-1 or 3/1 00:00:00 (midnight) on March 1 of the current year 

2011 00:00:00 (midnight) on the current month and day in the 
year 2011 

25 00:00:00 (midnight) on the 25th of the current month 

t 00:00:00 on the current date (today) 

y 00:00:00 on the previous date (yesterday) 

tue 00:00:00 on the most recent Tuesday 

 

Reference-time Abbreviations or Fixed Times with a Time Offset 

When included with a fixed time or a reference-time abbreviation, a time offset adds 
or subtracts from the specified time.   

Input Meaning 

*-1h One hour ago 

t+8h 08:00:00 (8:00 a.m.) today 

y-8h 16:00:00 (4:00 p.m.) the day before yesterday 

mon+14.5h 14:30:00 (2:30 p.m.) most recent Monday 

sat-1m 23:59:00 (11:59 p.m.) last Friday 

 

Time Offsets 

Entered alone in a time field, time offsets specify a time relative to an implied 
reference-time. The implied reference-time depends on the field where you enter the 
expression: 

• For a start time, the reference-time is the current clock time.  

• For an end time, the reference-time is the start time. 

• For a single time stamp, the reference-time is the current clock time. 
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Time field Input Meaning 

Start time -1d One day before the current clock time (24 
hours before the current clock time) 

End time +6h Six hours after the start time 

End time -30m 30 minutes before the start time 

Time stamp -15s 15 seconds before the current clock time 

1.3.4 Future Data 

Future data is data associated with a future time stamp. Data Archive 2015 allows 
storage and retrieval of data with time stamps beyond current time, allowing you to 
store data within a time range of January, 1970 through January, 2038. With Data 
Archive 2015 you can capture and analyze data with future time stamps, and use PI 
visualization tools to graphically create possible forecasts or predictions for your 
business. 

Just as with historical data, to specify inputs for timestamps, you can enter time 
expressions previous discussed fixed time, reference times, and reference-time 
abbreviations or fixed times with a time offset.  The difference being the timestamp 
will be in the future. Some example expressions are: 

 

Input Meaning 

*+1h An hour from now 

t+3d Three days from today at midnight 

Y+1y A year from yesterday 

 

1.3.5 How Does the PI System Adjust for Time Zones and DST? 

The short answer is: we do not! 

When we collect data, we convert it to UTC (Universal Coordinated Time), or what 
used to be called Greenwich Mean Time (GMT). This means that each day has 
exactly 24 hours. The local machine clock of the user looking at the data makes any 
adjustments for time, such as time zone or DST. 

If your region observes DST, once a year the day will look like it has 23 hours and 
another 25, but the PI Server never knows anything other than 24-hour days. 

In addition, because the clients and PI Server know what time zone they are in, the 
data can be viewed with respect to the server time or the client time. This is 
determined by a setting in the client tool. 
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1.3.6 Exercise – PI System Times 

 

This exercise is designed to maximize learning in a specific topic area.  You 
are invited to watch what the instructor is doing and perform the same steps 
at the same time, or your instructor will have instructions and will coach you 
if you need assistance during the activity. 

Problem Description 

Determine the “real” dates and times indicated by the PI System times in the table 
below: 
(assume now: Tuesday, 20-May-2014 10:12:23 AM) 
 

Abbreviation Answer 

* - 30m  

T-1d  

y + 8h  

12  8:  

Tuesday – 2d  
 

 

Express the following times in valid PI System time abbreviations: 

 
 

Abbreviation Answer 

Today at 6:30 AM  

Monday at 5:45 am  

12 hours ago  

The first day this 
month 

 

Tomorrow at 7:00 AM  

2 hours from now  

 

 



Introducing PI Manual Logger 

 

Page 8 

 

2. Introducing PI Manual Logger 

PI Manual Logger (PIML) is a set of client applications for manually entering data to 
the PI Data Archive.   

 
Your facility may have a significant amount of data that cannot be collected 
automatically from instrumentation and control systems. PIML provides these 
alternative data entry methods: 

• Enter data using PI Manual Logger data entry screens on a PC. 

• Enter data using an HTML5-compliant browser on mobile devices that use 
Apple iOS, Google Android, and Windows Phone operating systems. 

• Enter data on a Microsoft Windows Mobile device, a Windows Vista/7 or 
Windows 8 laptop, or a Tablet PC. You can review, edit, and approve the 
data on a PC before you transmit it to PI Data Archive. 

 

2.1 Architecture and installation components 
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The PI Manual Logger product suite is distributed in 3 install kits, each comprises 
the following components: 

Kit Component Description 

PI Manual Logger 
2014 
  
  

PI Manual Logger PC 
Client 

You use the PC Client to configure tours and enter 
data collected from field equipment. You review, 
edit, or approve the data on the PC Client before 
sending it to PI Data Archive. (It is not just a client 
application that allows you to run tours from a PC. 
It is the ONLY administrator application.) 

PI Manual Logger 
Windows Services 
(optional) 

You use the Windows Services to check the 
central SQL database and determine whether it 
needs to update cached data, update tag 
attributes or send queued future data to PI Data 
Archive. 

PI Manual Logger Web 
Services (optional) 

You use this feature to transfer tours and tour runs 
wirelessly through ASP.NET 2.0 Web Services 
interface from PI Manual Logger Mobile 2012. 

PI Manual Logger 
Web 2017 R2 

PI Manual Logger Web You use your HTML-5 compatible web browser to 
enter tour run data. 

PI Manual Logger 
Mobile 2012 

PI Manual Logger Mobile 
2012 

You use PI Manual Logger Mobile 2012 to collect 
data from field equipment with a handheld 
Windows Mobile device. You can transfer this data 
to the PC Client wirelessly if the device supports a 
wireless connection, or by cradling the device. Use 
the barcode feature to scan equipment to identify 
tags and enter data. 

In addition, the architecture diagram above also shows 2 other key components/machines that 
are not part of the PIML install kit: 

o SQL Server - holds the PI Manual Logger backend database (PimlWindows). The 
metadata for PIML, i.e. tours, users, user groups, historical tour runs are stored in this 
backend database. The metadata is provided to the PC Client and to PI Manual Logger 
Web so that the application can function.  

o PI Data Archive - the server where PI tags are obtained from to be placed on tour, and 
also where data is being sent to. Each instance of PI Manual Logger can write to one PI 
Data Archive or PI Collective. If you need to write to multiple PI Data Archives, you will 
need to manually change the configuration of PIML to connect to the other Data Archive. 
You are not able to write to multiple Data Archives/ Collectives at the same time.  

For installation instructions, please consult the PI Manual Logger Administrator Guide. 

This course will not go into much detail on PI Manual Logger Mobile and the PI Manual Logger 
Web Services as they have both mostly been replaced by PI Manual Logger Web. 

 

https://docs.osisoft.com/bundle/pi-manual-logger/page/pi-manual-logger-administrator-guide.html
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2.1.1 Architecture in this training environment 

There are four servers in this training cloud environment, all within the PISCHOOL 
domain. Key software installed on each server are summarized below: 

PISRV01 

• PI Manual Logger PC Client 

• PI Manual Logger Windows Services 

• SQL server 

• PI Data Archive and Asset Framework 

• Microsoft Excel with PI Builder and PI DataLink 

PIWEB01 

• PI Manual Logger Web 

• Google Chrome 

• Microsoft Excel with PI Builder and PI DataLink 

PICLIENT01 

• Google Chrome 

• Microsoft Excel with PI Builder and PI DataLink 

PIDC 

• Domain Controller 

 

 

2.2 Terminology 

Tour – a configuration that consists of specific PI tags to facilitate data collection. 

 

Tour run – a set of values, statuses, comments and timestamps entered for tags of a 
tour at a specific time. 

 

Tag group – Associate tags within a tour by placing them into a tag group. The tag 
group can be a piece of physical equipment or a set of measurements for a process 
that are usually measured together. 

 

Consult the user guide for a full list of PI Manual Logger terminology. 

https://docs.osisoft.com/bundle/pi-manual-logger/page/pi-manual-logger-terminology.html
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3. Security and user management 

3.1 PimlWindows SQL database security 

To use PIML PC Client, end users need access to the PimlWindows SQL database, 
specifically the db_datareader and db_datawriter roles for basic read/write privileges. 

Consult the user guide for steps to add a user account to PIMLWindows database. 

If a user only uses PIML Web to collect data (i.e. does not need to use PIML PC 
Client at all) AND PIML Web is configured to not delegate end user credentials to the 
SQL server, then the end user account does not need permission on the 
PimlWindows SQL database. We will discuss more about PIML Web in a later 
chapter.  

 

 

3.1.1 Exercise - Add a user account to PIMLWindows database 

 

This exercise is designed to maximize learning in a specific topic area.  You 
are invited to watch what the instructor is doing and perform the same steps 
at the same time, or your instructor will have instructions and will coach you 
if you need assistance during the activity. 

Problem Description 

PIML users need read/write access to the PimlWindows SQL database. 

 

Approach 

Using SSMS on PISRV01, create new SQL logins for PIML users and assign the 
necessary permissions to the database. If there are many users, AD group can be 
leveraged for better management, i.e. create one login just for the AD group that 
contains all PIML user accounts. 

 

  

https://docs.osisoft.com/bundle/pi-manual-logger/page/add-a-user-account-to-pimlwindows-database.html
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3.2 PI Data Archive security 

PI Data Archive security is configured in relation to PI Manual Logger to govern:  

• what users connect to PI. 

• what users can read and write to what tags. 

o Users need tag read access to build tours and see previous values. 

o Users need tag write access to send data from PI Manual Logger. 

▪ If PISDK buffering is used – then pibufss does the actual 
writes to PI tags, so pibufss on the given PI Manual Logger 
station must have write access to the tags. 

 

This can be configured by creating: 

• PI Mappings for all Manual Logger AD users/groups (preferred), or 

• PI Trusts (not recommended; less secure than PI Mapping) for 
PimlWindows.exe from each workstation. 

 

These PI Mappings/PI Trusts are then assigned to a PI Identity that has the required 
read/write permissions on the PI tags. 

 

 

3.2.1 Exercise – Configure PI Data Archive Security 

 

This exercise is designed to maximize learning in a specific topic area.  You 
are invited to watch what the instructor is doing and perform the same steps 
at the same time, or your instructor will have instructions and will coach you 
if you need assistance during the activity. 

Problem Description 

PI Manual Logger users need to be able to retrieve PI tag properties, as well as read 
and write data. 

Approach 

Create a new PI Identity PIMLUser reserved for PI Manual Logger access needs. 

Create PI Mapping for any PI Manual Logger windows users to access PI. If there 
are many users, mapping to AD groups is preferred. 
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3.2.2 Exercise – Create PI Digital State Sets and Tags 

 

This exercise is designed to maximize learning in a specific topic area.  You 
are invited to watch what the instructor is doing and perform the same steps 
at the same time, or your instructor will have instructions and will coach you 
if you need assistance during the activity. 

Problem Description 

Create PI tags and Digital State sets for manual data collection.   

Approach 

Use the following files in C:\Class folder to quickly build digital state sets and PI tags: 

SMT_DigitalStates_PIML.csv 

PIBuilder_Tags_PIML.xlsx   (identity PIMLUser must first exist) 

 

In most cases, all manual data should be recorded. 
• Exception = 0% 
• Compressing = Off 
 
For more details about exception and compression, please see YouTube video Exception and 
Compression Quick Summary. 

  

https://www.youtube.com/watch?v=6-scv3oQ7Kk
https://www.youtube.com/watch?v=6-scv3oQ7Kk
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3.3 PIML security (Users and Groups) 

3.3.1 Default account for first time login  

Launch PI Manual Logger PC Client and log in using the default account that comes 
with every new install: 

Name: piml 

Password: piml 

 

After logging in, the Getting Started dialog box appears. This dialog box provides 
shortcuts to some common tasks, such as add new users or groups, manage tours, 
etc. You can close this window and open it later by clicking on PIML > Getting 
Started Window.  

 

 

The status bar at the bottom of the main window shows the current PI Manual 
Logger user, current SQL Server database, the current connected PI Data Archive, 
any status messages, and the current version of the main PI Manual Logger 
application. Click the information on the status bar to change settings or show 
details. 
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3.3.2 PI Manual Logger Users and Groups 

Go to PIML > Manage User Database, or the Getting Started Window > Manage 
Users and User Groups 

• Users belong to groups. 

• Users belonging to PIMLADMINS group are administrators by default. This is 
defined in Tools > Global Options > Security Settings 

• Management and data entry rights are defined at a tour level (during tour 
configuration) by assigning groups 

 

 

In the Users pane, the following actions are possible. 

• Add a new user 

• Change or reset the password of an existing user 

• View or change the properties and group memberships of a user 

• Delete a user 

 

In the Permission Groups pane, the following actions are possible. 

• Add a new group 

• View or change group properties and its user memberships 

• Remove a group 

 

Note: PI Manual Logger Users and Groups is separate from PI security! 
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3.3.3 Exercise – Create PI Manual Logger Users and User Groups 

 

This exercise is designed to maximize learning in a specific topic area.  You 
are invited to watch what the instructor is doing and perform the same steps 
at the same time, or your instructor will have instructions and will coach you 
if you need assistance during the activity. 

Problem Description 

You have installed PI Manual Logger and would like to verify your connection 
settings with the PI Server and the SQL Server.  Additionally, you must now create 
users before data can be collected. You will create two groups, the Operators group 
for the data collectors and the Supervisors group to approve and submit data.  The 
Supervisors group will also have to be selected as the Admin User Group. 

Approach 

Using the PI Manual Logger menu or the status bar, verify the following: connection 
to the desired PI Server, connection to the SQL server, and user logged in.  

Create four new users: Paul, Sam, Brad and Tony. (Beware of case-sensitivity) 

Create two new groups: Supervisors and Operators.  

• Paul and Sam will belong to the Operators group and they will be the data 
collectors.  

• Brad, Tony and the default piml user will belong to the Supervisors group; 
they will review, approve and submit data.  

Make the Supervisors group as the Admin User Group. 

  



Security and user management 

 

Page 17 

 

3.3.4 Full Access Group vs. Data Entry Group 

Management and data entry rights are set during Tour Configuration by assigning 
groups. 

• Full Access Group can manage the tour. Members of such groups can modify 
the tour, enter and review data for the tour, as well as delete tour runs. 

• Data Entry Group can only enter data for the tour. Members of such groups 
can only enter and modify tour run data. They cannot delete tour runs. 
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4. Tour configuration management 

4.1 Tour Basics 

In PI Manual Logger, a tour is a list of tags grouped together in order to facilitate data 
collection. The Tour List can be open by clicking on Tours > Tours List, here you 
can create, modify, and delete tours from the PI Manual Logger database. To 
create/edit tours, you must be a member of the PIMLAdmins group. Otherwise, the 
Tour Configuration dialog box opens in read-only mode. 

What makes up a tour: 

• Tour Name 

• Full Access Group 

• Data Entry Group 

• Tag List 

• Groups (optional) 

• Description (optional) 

• Comment Tag (optional) 

• Schedule (optional) 

• Tour Options 

• Tag Options 

Tour options are settings that pertain to the entire tour.  There are group and tag 
options as well.  The more “specific” level the option gets priority (tag > group > tour).  
For instance, if there is both scheduling set on a tour and a tag, the tag scheduling 
takes precedence. 
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4.2 Tour Features 

Groups are a way to organize tags within a tour. Groups may contain tags and may 
contain groups, which can be represented in a hierarchy. A common use of groups is 
to represent equipment.  The tag list view from a PI Manual Logger tour configuration 
is shown below.  In this example, there is a group Boiler 1902, which contains tags 
that are various measurements on the boiler. 

 

Many configuration options for tags apply to groups as well, such as scheduling, 
barcode assignment, comments, CMDE – all of which will be covered later in the 
workbook. 

 

Scheduling can be set for tours. Scheduling provides a guide for collection times; 
it does not enforce or alarm collection times.  When configured, scheduling 
dictates the suggested timestamp for a tour.   In addition, group and tag scheduling, 
if configured, can dictate whether tags are due on a given tour run. 

On PI Manual Logger on a PC, in the tag list view, icons denote whether a tag is 

• due  ,  

• not due ,  

• data has been entered ,  

• data has been entered and is in limit violation .    

 

Conditional Manual Data Entry (CMDE) allows one to add a calculation/logic to a 
tag or group to determine if it should be due for collection. CMDE is another form of 
scheduling but is calculation/logic based rather than clock based.  

An example of a CMDE formula: 

If(CurrentValue(“Tag1”)+CurrentValue(“Tag2”)<=100, CollectNow(), Skip()) 

 

Refer to the user manual for CMDE syntax details. 

https://docs.osisoft.com/bundle/pi-manual-logger/page/conditional-manual-data-entry-cmde.html
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CDME can be defined for a tag on the Tag Entry Options tab when configuring a tour 
(see next figure).  It can also be defined for a group on the Tag Group Configuration 
tab when configuring a tour. 

 

CMDE IntelliSense feature  

• CTRL + SHIFT. Prompts with a list of CMDE functions along with their 
descriptions 

• CTRL + T. Prompts with a list of tags in the tour 

• CTRL + O. Prompts with a list of CMDE operators 

 

Available Digital States 

All PI tags, even those that are numeric such as a float32, can have a digital state 
event. The state value could be used to indicate that an equipment is down; a 
sample is bad, etc. To make digital states available for entry on a tour, they are 
assigned using the Tour States button while configuring a tour. Only states from the 
SYSTEM state table are available. 

  

States that are assigned to a tour are available during data entry in a drop down box. 
Note that these digital states are different from those a digital tag. If a digital tag is 
included on a tour, all of its states are available for entry. 
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Barcodes 

   

You can use a barcode as an alias for a tag name. You can also assign a barcode to 
a tag group (such as a piece of equipment, an area, or a building). Assignment of the 
barcode is done during tour configuration. 

When a barcode is scanned, PI Manual Logger moves to the associated tag or the 
first tag of the associated group. This aids in navigation, so one is freed from 
sequential data entry dictated simply by the tag order of the tour. 

 

 

Barcode feature is used with PI Manual Logger Web or PI Manual Logger Mobile 2012. For 
more details: 

• How to use barcode in PI Manual Logger Web 

• PI Manual Logger Mobile 2012 supported scanning devices 

 

Comments 

Entering comments  

There are several configuration options for comment entry: 

• No configuration – data entry is free-form text. 

• Configure comment templates (essentially a comment pick list) using the 
Comment Template Builder (Tools > Comment Templates).  Comment 
Templates are global and not tour specific. The templates can be  

a. newly created using the builder 

https://customers.osisoft.com/s/knowledgearticle?knowledgeArticleUrl=000030612
https://docs.osisoft.com/bundle/pi-manual-logger/page/supported-scanning-devices.html
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b. imported from existing Digital State sets 

c. imported from Reason Tree codes (built using PI SMT) 

 

 

Storing comments  

Options for storing comments are: 

• If no configuration is done, then comments on tag values are stored as 
annotations. 

• The other option is to define a comment tag per tour tag (during tour 
configuration). This comment tag will then receive the comment. 

There is also an option to write/store comments to both annotation and comment tag. 

 

 

Tour comments 

A comment tag may also be assigned to tour.  If so, a user may enter a comment for 
the entire tour. 
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A summary of PI Manual Logger comments options shown in table below: 

Where Comments 
an option? 

Dropdown 
list 
available? 

Stored in 
annotations? 

Stored in comment 
tags? 

Tour Run Yes Y if comment 
templates used 

NA Yes if a tour comment tag 
is defined.  If not, only 
stored in PI Manual Logger 
DB. 

Tour run group Yes Y if comment 
templates used 

NA Yes if a tour comment tag 
is defined.  If not, only 
stored in PI Manual Logger 
DB. 

Individual tag 
data value 

Yes Y if comment 
templates used 

Yes in all cases. Yes if a comment tag is 
defined for the tour run 
tag. In this case both 
annotation and a value to 
comment tag are stored. 

 

 

Viewing Tag Data and Properties 

Tag data is available in PI Manual Logger in several modes:   

• a trend during tag configuration,  

• a trend and list of previous values during data entry. 

PI tag attributes are available during tour configuration. 
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4.3 PI Manual Logger Options Overview 

There are sets of options in PI Manual Logger: tour options, user options, and global 
options. We will review some noteworthy options, however a full explanation of every 
option can be found in the user guide. 

4.3.1 Tour Options 

The tour options are specific to a given tour. The options are accessed in the left 
pane of a tour definition. 

 

https://docs.osisoft.com/bundle/pi-manual-logger/page/tour-options.html


Tour configuration management 

 

Page 25 

 

 

Most of the options are self-explanatory.  Note that some such as Navigate through 
due tags only are specific to mobile devices. 

 

Some noteworthy options are:  

Create annotation to record user name when sending data to PI 
Select for PI Manual Logger to create an annotation together with the PI tag value when 
sending manual data to the PI Server. After the annotation and tag value are sent to the PI Data 
Archive, you can view them with the built-in Annotation viewer inside PI Manual Logger in 
addition to the PI Manual Logger Trend control. You can also use PI ProcessBook or PI 
DataLink to retrieve and view the recorded user name.  

 
Data Entry Only Group can send data to PI 
Select to enable users in the Data Entry Only group to send collected data to PI tags. However, 
they are still prohibited from performing other tasks only permitted to members in the Full 
Access group, such as managing tours or users. 
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4.3.2 User Options 

You should open Tools > User Options and we will explore them as a class. 

 

 

4.3.3 Global Options   

You should open Tools > Global Options and we will explore them as a class.  You 
must be a PIML admin to access this menu. 

 

Of special note, if your deployment may have several operators writing data to the database, it 
is recommended that you select the Enable SQL Server Snapshot Isolation Level check box. 
This facilitates any read operations that are made during the write operations. Otherwise delays 
may occur due to the multiple write transactions. 

 

 

The bulk of the options are the Message Logging, which dictates what information 
will be logged. The messages can be reviewed at menu PIML > Message Log 

 

https://docs.osisoft.com/bundle/pi-manual-logger/page/specify-user-preferences.html
https://docs.osisoft.com/bundle/pi-manual-logger/page/configure-global-options.html
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The Security Settings are important as this where the Admin User Group is specified 
(by default PIMLAdmins).    

 

 Caution: If you are a member of the current Admin User Group and you it to a group 
you do not belong to, you can no longer access the Global Options dialog box. 

 

 

4.4 Data Validation 

Limits and Trigger Actions  

Limits can be set per tag during tour configuration.  Limits may be absolute values or 
referenced tags.  A variety of actions (trigger actions) upon violations may be 
defined. Examples include reject or accept value. 
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4.5 Exercise – Create and Configure Tours 

 

This exercise is designed to maximize learning in a specific topic area.  You 
are invited to watch what the instructor is doing and perform the same steps 
at the same time, or your instructor will have instructions and will coach you 
if you need assistance during the activity. 

Problem Description 

You must create two new tours (one for lab data and one for reactor data) for your 
newly installed PI Manual Logger.  You will then add tags to your tour and order the 
tags in the order that they need to be collected using tag groups.  At the end of the 
exercise you will create an additional tour for boiler data.  You anticipate that the 
operators may have comments on the lab values they record.   

 

Approach 

Tour 1: Lab Data 

• Using the Tour Creation Wizard you will create a Tour called Lab and add all 
the tags associated with the lab (prefix PIML_FinishedProduct). On the 
PIML_FinishedProductAppearance, the operator may need to comment. 
Comment templates can facilitate operator use of comments. 

• In addition, digital states can be defined for a tour. These are different from 
states for a tag of digital point type.  These provide states that can be chosen 
for any tag value. For example for a numeric sample value, Sample Bad may 
be entered. These digital states are defined on a tour basis. Assign digital 
states for the Lab tour. 

 

Tour 2: Reactor Data 

• Using the New Tour dialog box you will create a second tour called Reactor 
(without using the tour creation wizard). Save the tour and close. Using the 
Tour Configuration window edit the Reactor tour by adding all the tags 
associated with the reactor (prefix PIML_Reactor).  Organize the tags into 
two different groups and experiment with ordering the tags. 

 

Tour 3: Boiler Data 

• Use what you learned to create a Boiler Data tour. 
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4.6 Approval Process for Sending Data to PI 

 

 

If you check Manual data must be submitted for approval it will only allow someone 
in the full access group to send Data to PI.   

Setting Data Entry Only Group can send data to PI to OFF (unchecked) will only 
allow regular users to be able to submit data for consideration.   

If you want to really review the data and not have it automatically written to PI then 
make sure, you uncheck Auto Send Data to PI.  Otherwise, you run the risk of 
sending data to PI by accidentally opening and closing a tour run. 
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4.7 Exercise – Define Collection Schedule and Options 

 

This exercise is designed to maximize learning in a specific topic area.  You 
are invited to watch what the instructor is doing and perform the same steps 
at the same time, or your instructor will have instructions and will coach you 
if you need assistance during the activity. 

Problem Description 

You need to create a data collection schedule for one of your recently created tours 
(Reactor only). Configure the tour so that a signature is required and the data is 
reviewed before being sent to the PI server. 

Approach 

Open the Reactor tour and create an hourly collection schedule.  

Additionally, configure the tour with the following options: the tour requires a 
signature by the operators; the supervisors must review the data before being sent to 
the PI Server, default the tour time to the current timestamp.   

Also, add a LoLo, Low, High and HiHi Limit of 150, 200, 420 and 470 to the Data 
Validation tab of the Temperature tag.  Add an action to require an operator 
comment when the LoLo or HiHi limits are violated, and an operator signature when 
the Low or High limits are exceeded.   

Lastly add the following digital states to the tour: Unit Down and Out of Serv.  These 
digital states are part of the PI System digital state set. 
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4.8 Exercise – Conditional Data Entry and Operator Instruction 

 

This exercise is designed to maximize learning in a specific topic area.  You 
are invited to watch what the instructor is doing and perform the same steps 
at the same time, or your instructor will have instructions and will coach you 
if you need assistance during the activity. 

Problem Description 

Open the Reactor tour and specify a conditional data entry for the capacity, cooling 
water intake and valve tags.  Add an operator instruction for the reactor ValveOut1 
tag.  

Approach 

Open the tour definition and specify a conditional data entry for the Reactor 
Capacity, such that the tag only collected if reactor pressure <= 10 or reactor 
pressure not equal “UnitDown”. 

Under the Reactor ValveOut1 tag provide operator instructions to ensure both relief 
valves are closed but unlocked. 
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4.9 Exercise – Export and Import Tour Configuration 

 

This exercise is designed to maximize learning in a specific topic area.  You 
are invited to watch what the instructor is doing and perform the same steps 
at the same time, or your instructor will have instructions and will coach you 
if you need assistance during the activity. 

Problem Description 

In this activity, you will export tour configuration data to an XML file and modify the 
file outside PI Manual Logger. There are several reasons why you might want to 
export and import tours: 

• To transfer tours from one PI Manual Logger database to another, for 
example when moving data from a development to a production environment. 

• To bulk load tour configurations. 

• To edit tour configurations in an Excel spreadsheet. It is often easier to re-
sequence PI tags this way. 

• To rename PI tags. This task is easier to accomplish in an XML file rather 
than in PI Manual Logger. 

• To export data to Technical Support for troubleshooting. 

Approach 

Export all the tours you have created in PI Manual Logger.  

Open the XML file in Excel using the PI Manual Logger tour configuration schema 
file. 

• Modify the Reactor tour the following way: change the HiHi limit of the 
temperature tag to 500. 

• Modify the Lab tour in the following way: Re-sequence the tags such that the 
first tag to collect data for is pH, then Density, BoilingPoint and lastly 
Appearance. 

Import back all the tours into PI Manual Logger. Verify that the changes to the 
Reactor tour were saved.  



Collecting Data with Tour Run 

 

Page 33 

 

5. Collecting Data with Tour Run 

Start a tour run 

 

 

Enter data 

 

 

Finish options 
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Check tour run status 

To review a tour run status, select Tours > Tour Run List (Manual Data Entry and 
Review). This launches the Select a Tour Run window that lists available tours and 
tour runs that have already been created for each tour. 

 

In the Tour List pane, select the tour you want. The tour runs associated with the 
selected tour are displayed in the Tour Run List pane. 

The Tour Run List pane displays the status of existing tour runs for the tour you have 
selected. Status values are: 

Status Description 

Ad hoc 
Tour run was performed but all conditional checking (such as clock scheduling 
and CMDE) was ignored. 

Archived All non-empty values in the run have been written to PI Data Archive. 

Completed 
The run has been completed but the values have not been archived. This 
should only occur when approval is needed for data. Runs with this status have 
been successfully stored in SQL. 

In Progress Data entry has started but is incomplete. 

Queued 
The run has been completed but contains future data that cannot be sent to PI 
Data Archive yet. Queued data (or future data) is not placed in the queued data 
list to be sent to PI Data Archive until the data is approved. 

Submitted Data entry is complete and is ready for review. 
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5.1 Exercise – Create and Save Tour Runs 

 

This exercise is designed to maximize learning in a specific topic area.  You 
are invited to watch what the instructor is doing and perform the same steps 
at the same time, or your instructor will have instructions and will coach you 
if you need assistance during the activity. 

Problem Description 

In this exercise, you will collect data with PI Manual Logger by creating tour runs. 
You will then view a history of previous values and will save the data. 

Approach 

Create new tour runs for the Lab and Reactor tour and enter values for each one of 
the tags using the Data Entry dialog window. Preview a trend of previous values by 
clicking on the trend icon next to the tag value input box. Preview some of the 
previous values by clicking on the previous values tab in the tag info pane. (There 
may not be any, if the tags are newly created). 

Finally, repeat for the Boiler tour. 

 

5.2 Collecting future data 

PI Manual Logger does not support sending future data (more than 10 minutes into 
the future) to the PI Data Archive. When future data is collected, the data is stored in 
the queued table (tour run status shows Queued) until it needs to be sent to PI Data 
Archive when the timestamp becomes current.  

You can do this manually, or have PI Manual Logger Windows Services send the 
queued data to PI Data Archive automatically on a scheduled basis after the 
timestamp of the queued data becomes current. 

Procedure 

1. To send the queued data manually, select PIML > PI Tags and Digital States. 

2. Click the Queued Data tab. A list of all queued data that is now viable (less 
than 10 minutes into the future) is displayed. 

3. Choose one of the following actions: 

a. Click  (the Send Queued Data to PI button) . 

b. Right-click and select Send to PI. 

All queued data that is now viable (less than 10 minutes into the future) is sent to PI 
Data Archive. 

 

Note: We will discuss more about PI Manual Logger Windows Services in a later 
chapter. 
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5.3 Exercise – Create and Save Tour Runs with future data 

 

This exercise is designed to maximize learning in a specific topic area.  You 
are invited to watch what the instructor is doing and perform the same steps 
at the same time, or your instructor will have instructions and will coach you 
if you need assistance during the activity. 

Problem Description 

In this exercise, you will repeat the data collection process by creating a tour run of 
the Lab tour, but with a timestamp in the future. 

Approach 

Create a new tour run for the Lab tour and enter values for each one of the tags 
using a timestamp of 20-30 minutes into the future. 

Check that the tour run has a status of Queued. Verify that the future data is not sent 
to the PI Data Archive. 

When the timestamp becomes current, manually send the queued data to PI. 
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6. Tour Run Reviews and Maintenance 

6.1 Tour Run Reviews 

Users who belong to the Full Permission Group assigned to a tour can review and 
modify any submitted and unarchived tour run data before sending it to PI Data 
Archive. 

Procedure 

1. Select Tours > Tour Run List (Manual Data Entry and Review) or press F6. 

2. In the Tour List, select the tour you need to review. 

3. Optional. To group the tours in the Tour Run List by Completed status, click 
the Status column heading. 

4. Double-click the completed tour you need to review, or select it and click 

Open . 

5. Click Yes in response to the confirmation prompt. 

6. In the Data Entry window, review and modify (e.g. correct/re-enter) the data 
as appropriate. 

7. Click Approve . The Data Entry window closes and the status of the tour 
run changes to Archived. 

 

Besides reviewing and modifying tour run data, here you can also perform other 
tasks such as: 

• Review status of runs. 

• Check history of runs: provides additional details such as user, workstation 
ID, etc… 

• Search tour runs. 

• Delete selected tour runs. 
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6.1.1 Exercise – Approve the Data for the PI Archive 

 

This exercise is designed to maximize learning in a specific topic area.  You 
are invited to watch what the instructor is doing and perform the same steps 
at the same time, or your instructor will have instructions and will coach you 
if you need assistance during the activity. 

Problem Description 

You want to review the data collected in the previous exercise before it is written to 
the PI Server. 

Approach 

Go into the tour run list.  Select the Reactor tour from the top panel and then double-
click the specific run from the lower panel.  Review the tour run and the values 
collected.  You can modify or remove any bad values.  You can also add or edit any 
comments.  Approve and send the data to the PI server.  
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6.2 Tour Run Maintenance 

You access the Tour Run Maintenance window from Tours > Tour Run Maintenance. 

Note: Only users that are members of the PIML administrative group can access this 
function. 

Here in this Tour Run Maintenance window, very much like the Tour Run List 
window, you can manage and review unapproved tour run data stored in the 
database. You can also remove any unapproved tour run data. 

On top of that, there is also an option here for you to delete/remove older tour runs 
by specifying a time range. OSIsoft recommends that you periodically remove old 
tour runs that have been archived (that is, sent to PI Data Archive) to improve PI 
Manual Logger performance. 

 

 

 

 

Note: Approved tour run data is saved in the target PI points. OSIsoft recommends 
that you use PI client tools, such as PI ProcessBook and PI DataLink, to view the 
approved data available. 
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7. PI Manual Logger Audits 

Auditing PI Manual Logger On the PI Server 

Security on the PC application is integrated with PI trusts or PI Mapping. When users 
log in to a PC workstation and start PI Manual Logger, they are authenticated against 
the established PI trust or PI Mapping on the currently connected PI Data Archive. 
After they are authenticated to this PI Data Archive, they can access data in the PI 
Data Archive. All connections to the PI server are recorded in the PI server message 
log. 

Changes to PI data (such as from a PI Manual Logger user) can be trailed if PI Auditing is 
enabled.  See the Auditing the PI Data Archive section of the PI Server manual for details. 

 

Auditing on User Database Changes 

Administrators can audit changes in the user database, such as user password 
changes and user group relationship changes. Click Tools>Global Options.  Select 
the Message Logging tab. Select from these options: 

• Log user group membership changes. 

• Log user password change events. 

• Log Admin user group changes. 

 

Auditing on Tour Definition Deletion and Creation 

You can audit tour definition creation and deletion events. Click Tools>Global 
Options.  Select the Message Logging tab. Select from these options: 

• Log tour definition creation events. 

• Log tour definition deletion events.  
 

 

Auditing on Data Transfer 

All successful data transfers from PI Manual Logger to PI Data Archive is audited 
and logged into the PI Manual Logger database. To view these logs, use the 
Message Log Viewer.  

  

https://docs.osisoft.com/bundle/pi-server/page/auditing-the-pi-data-archive.html
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Auditing on Manual data must be submitted for approval tour option 

If the tour option Manual data must be submitted for approval is set to True, submit 
and approve events can be logged to the Message Log if the following options are 
enabled: 

• Log tour run data approval events 

• Log tour run data submit events 

 

Auditing on Data Changes in PI Manual Logger 

If a user makes changes to an existing tag value, its timestamp, or its comment, the 
action is audited and saved in the tour run audit trail. You can view the audit trail in 
the Tour Run Audit Log. 

From PIML PC Client, Tours > Tour Run Maintenance > double click a Tour Run > 
Audit Log tab. 

 

Auditing on duration of tour runs 

The duration of a tour run is recorded and saved in the dbo.tblTourRunAuditLog 
table in the AuditLog field. The format for this information is as follows: 

Total Duration: 00:00:29 

 Session 1: Duration: 00:00:04 Start Time: 2017-06-

30T17:05:46.789Z End Time: 2017-06-30T17:05:51.245Z 

 Duration Between Sessions: 00:00:14 

 Session 2: Duration: 00:00:24 Start Time: 2017-06-

30T17:06:05.518Z End Time: 2017-06-30T17:06:29.909Z 
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8. PI Manual Logger Message Logs 

The following activities and events are saved in the message log for auditing 
purposes: 

• Successful or failed tour creation, modification, and deletion, including the 
details on which tour and which user made the change. 

• Successful or failed archive action for tour run data, including details on 
which user was involved in the action. 

• Other failed access events. 

 

To view the history of the PI Manual Logger message logs, select PIML > Message 
Log. 

In the Message Log Viewer dialog box, you can view logs in Grid View and Plain 
Text View by clicking the corresponding tabs. To view all logs in the PI Manual 
Logger database, click Show Saved Logs.  

Note: Show Saved Logs displays 30 days at a time. Continue to press the Show Saved Logs 
button to view additional days. 
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9. PI Manual Logger Web 

9.1 Overview 

PI Manual Logger Web is an HTML5 based web application that enables users to 
enter tour run data using a web browser on a desktop or on a modern device, such 
as a tablet or smartphone. The application is served by the IIS Web Application (runs 
under PimlWebServiceAppPool), which is installed by the PI Manual Logger Web 
install kit. The install kit also creates additional stored procedures (SPROCs) in the 
PimlWindows SQL database that are used to allow the web application to retrieve 
and run tours.   

Note: PI Manual Logger PC Client must be installed and PimlWindows SQL database must 
exists BEFORE installing PI Manual Logger Web. 

The first time you want to launch PI Manual Logger Web, you must have a network 
connection to the web server to load tours into the browser cache. After that, a 
network connection is needed only when you want to: 

• Send data to PI Data Archive (or cache it in the PI Manual Logger database) 

Or 

• Update tour definitions (using “Refresh” button on the home page). Tour 
definition updates include previous values, historical values, changes to 
which tags are collected or to tag limits, and so on. 

Otherwise, data collection can be performed entirely Offline (i.e. no connection to PI). 
This is especially true when most plants do not have WiFi on the production floor as 
a safety precaution. Tour data is entered by users and saved in the browser cache. 
When users go back into the WiFi zone and have network connection ("online"), they 
can then submit the saved tour runs. 
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9.2 PI Manual Logger Web Data Entry 

To connect to PI Manual Logger Web, open a browser and enter a URL similar to the 
following: 

https://<webServer>/Piml.web 

The tours to which you have access are displayed on the home page. 

 

 

 

1. Select a Tour from the Tour List 

2. Click New Tour Run 

3. Use the individual data entry page to enter tour run data on a per tag basis, 
and in the tag sequence established during tour configuration. This is the 
default display for PI Manual Logger Web. 
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Individual data entry 

 

• Tagname is displayed immediately below the navigation buttons. The full 
group path to which the tag belongs in the tour is displayed under the tag 
name. 

• Descriptor, if defined, appears below the tag name. 

• Operator Instructions, if defined, under the Instructions label. 

• Value and Comments (optional) may be entered. 

• If the tag is digital type or digital states associated with the tour, the Value 
dropdown will list digital states. 

• Engineering Units, if defined, appear next to the Value label. 

• Limits, if defined, are displayed below the Value field. 

• Previous tag event is displayed after the Previous label 

• The timestamp associated with the current tag event is displayed. Depending 
on tour configuration settings, you can change the timestamp. 

• Historical values and Attributes (such as UOM, Zero, Span, Point Type, or 
Digital Set) are also available. By default these are minimized. 

• The blue barcode icon  (top right) is used for scanning or entering a 
barcode (if configured). 
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You can also switch to grid data entry view from the top right link.  

 

Grid-based data entry 

 

• Tags are initially organized by groups defined in your tour configuration. You 
can change it to have the rows grouped by any column value. 

• Default columns in grid data entry are Name, Description, Value, Previous 
Value, UOM, Comment, Timestamp, and Limits. You can also customize the 
columns and move them to different positions, as required. 

• The columns can be sorted 

• Expanding a row reveals a chart of previous values 

• See the user guide for a list of Grid-based data entry page controls 

 

Finally, when you hit the Save button, tour run data is sent to the PI Data Archive 
server if all of these conditions are met: 

• General Tour Option Manual data must be submitted for approval is false. 

• General Tour Option Auto Send Data to PI is true. 

• The data timestamp is not in the future. 

Note: Approval of tour run data (if required) can only be performed in PI Manual 
Logger PC Client. 

https://docs.osisoft.com/bundle/pi-manual-logger/page/data-entry-for-tag-lists.html
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9.2.1 Exercise – Enter and Save data with PI Manual Logger Web 

 

This exercise is designed to maximize learning in a specific topic area.  You 
are invited to watch what the instructor is doing and perform the same steps 
at the same time, or your instructor will have instructions and will coach you 
if you need assistance during the activity. 

 

Problem Description 

You want to enter data using PI Manual Logger Web. 

Approach 

Open a browser, go to the PI Manual Logger Web URL (http://webserver/PIML.web).  

Select the Boiler tour from the top panel.  Enter values and some comments.  Enter 
some of data using the grid view.  Send the data to the PI Data Archive. Confirm that 
the data and comments have been stored. 

Then, simulate collecting data in Offline mode and note the differences. 

 

  

http://webserver/PIML.web
http://webserver/PIML.web
http://webserver/PIML.web
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9.3 PI Manual Logger Web Security 

There are three ways to utilize Windows Active Directory (AD) credentials when 
using PI ML Web. Deciding which of the three options to use depends on your use 
case and security scenario. If possible, after considering the impact of each 
configuration option, use the first option below. 

Use the following flowchart to decide between the three options: 

 

 

Option 1: Authenticate with AD credentials to the web server and use a SQL login to 
perform all reads/writes on behalf of the PI ML Web user. This requires a SQL login, 
uses SQL authentication to connect to SQL, and only the SQL login requires 
read/write/execute permissions to the PimlWindows database. 

  

Option 2: Enable Kerberos delegation on the web server and pass through the AD 
credentials so that reads/writes to PI ML are performed by the authenticated user. 
This allows the AD user to read/write to specific tours. 

  

Option 3: Authenticate with AD credentials to the web server (IIS) and subsequently 
use the application pool identity for all reads/writes to PI ML. Option 3 will perform all 
tours reads and writes with the same identity regardless of the authenticated user. 
For example, every user allowed to authenticate to the web server will "see" tours 
and create new tour runs based on the PI ML permissions associated with the 
application pool identity. 

https://customers.osisoft.com/s/knowledgearticle?knowledgeArticleUrl=Configure-Security-for-PI-Manual-Logger-Web-Option-1
https://customers.osisoft.com/s/knowledgearticle?knowledgeArticleUrl=Configure-Security-for-PI-Manual-Logger-Web-Option-1
https://customers.osisoft.com/s/knowledgearticle?knowledgeArticleUrl=Configure-Security-for-PI-Manual-Logger-Web-Option-2
https://customers.osisoft.com/s/knowledgearticle?knowledgeArticleUrl=Configure-Security-for-PI-Manual-Logger-Web-Option-2
https://customers.osisoft.com/s/knowledgearticle?knowledgeArticleUrl=Configure-Security-for-PI-Manual-Logger-Web-Option-3
https://customers.osisoft.com/s/knowledgearticle?knowledgeArticleUrl=Configure-Security-for-PI-Manual-Logger-Web-Option-3
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10. PIML Windows Service 

10.1 Features 

• Windows Service that stores cached data in the PI Manual Logger database 
synchronized with the targeted PI Data Archive. 

• Periodically updates the cached tag values in the PI Manual Logger 
database. 

• Periodically updates the cached tag attributes and digital states in the PI 
Manual Logger database. 

• Periodically checks any queued future data in the PI Manual Logger database 
and sends them to the targeted PI Data Archive when the queued time 
passes. 

10.2 Architecture 

 

10.3 Configuration 

The account used for PI Manual Logger Windows Services needs: 

• db_datareader and db_datawriter database role membership to the PI 
Manual Logger SQL Server database, and  

• read/write permissions on the PI Data Archive for both point and data security 
for all PI Manual Logger tags. 

By default, PI Manual Logger Windows Services is scheduled to synchronize tour 
data with the target PI Data Archive every six hours. This is configurable to a 
minimum of one hour by changing the PulsorTime setting value in the 
PIPC\PimlWindows\PimlServiceSettings.xml file (requires restarting PI Manual 
Logger Windows Services). 
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11. Resources 

11.1 OSIsoft Learning Website 

The OSIsoft Learning website is located at https://learning.osisoft.com. This is the 
best place to learn more about the PI System. We have curated our online courses, 
instructor-led training, and hands-on labs in an easy to browse website. The platform 
is separated into learning paths, and for beginners, we suggest the User path. 

 

Online Courses 

Take a few minutes to click into the different learning paths and see the types of 
online courses offered for:  

• Users – who need to see the data in real time or build reports with PI System data. 

• Administrators – who keep the data flowing and support end users. These courses dive 
into the backend components of the PI System. 

• Developers – who write code to interact with the PI System programmatically. 

• Power Users – who are adept with the basics of the PI System and can boost their 
organization’s efforts through building an enhanced Asset Framework structure. 

• Project Managers – who need to lead initiatives to adopt or expand the PI System in the 
organization. 

Our online courses cover a wide range of topics and are on-demand. When you sign 
up for an online course, you will immediately gain access to the course material for 



Resources 

 

Page 51 

 

30 days along with a Training Cloud Environment for you to practice the concepts 
discussed in the course.  

You can also purchase a Training Cloud Environment separately from the courses if 
you want a place to explore the PI System outside of your company’s production 
environment; however, we recommend using your own development system 
whenever possible to create meaningful results with your company’s data as you 
learn from our online materials. 

 

Instructor Led Courses  

If you prefer having an instructor, you will want to check out our instructor-led Virtual 
or Classroom Courses. We have several training centers around the world for you to 
visit, so pick a location that is convenient for you (or combine some PI education with 
a vacation)! 

To browse the available training centers and courses, follow these steps: 

1. Click on “All Content” 

2. Use the filter on the left to select “Classroom” under “Content Type” 

3. Expand the “Location” category to browse our training centers 

4. View the available courses offered at your selected location 

a. Some training locations offer course taught in languages other than English, feel 
free to use the “Language” filter to further refine your course options. 

5. Click on the course that matches your interest and follow through registration 

 

If you want to view the course calendar, you can click on the calendar icon  

in the All Content page. 
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11.2 OSIsoft Learning YouTube Channel 

Visit our YouTube Channel (@ youtube.com/OSIsoftLearning) to learn about the PI 
System by watching any of our 1000+ free videos on YouTube!   

Playlists for various topics are available to help guide you through your training topic 
of choice from start to finish. 

 

 

11.3 PI Square – The online PI System Community 

PI Square (pisquare.osisoft.com) is your community to connect with peers worldwide, 
ask questions, share answers, meet others, and exchange ideas, to get more value 
out of your PI System. 

The PI Square community has places you go to collaborate, called Spaces. These 
spaces are generally named for a specific topic or purpose. Each space can contain 
multiple types of content, including discussions, documents, blog posts, polls, and 
more. Currently, PI Square has the following four spaces: 

• All Things PI - A general forum where OSIsoft Technical Support will keep watch to help 
answer questions and contribute to discussions. Use the product-specific spaces like PI 
Server or PI Visualization to find relevant content for whatever your needs may be. 

• PI Developers Club - Here we have tools and support for developers to create applications 
for the PI System.  

• Learning Forums - Our hub for students to interact and learn from each other while they 
pursue certificates in our on-demand online courses. 

• PI Square Groups – Join a group that speaks to your specific industry’s needs and learn 
from others in your field of their recommended best practices for projects on your horizon. 
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11.4 The Customer Portal 

The myosisoft.com website has many tutorials on how to support related activities 
as well as quick links to take you to commonly used support pages: 

 

OSIsoft Customer Portal Hints 

• How to Get an OSIsoft Customer Portal Login 

• How to Create a New Case 

• How to Download Products and Generate Licenses 

• How to Search for Articles 

• How to Manage Users 

 

From the Customer Portal, you can also:  

• Download any PI product your company is licensed for using.  

• View the PI System Roadmap to get information about the most current releases and 
what new features and products are on the horizon.  

• Login and view your open and previously closed Support Cases or create a new one.  

• Search through our Knowledge Base to try and troubleshoot any issues you may be 
having by referring to the rich collection of available KB Articles. 

 

Here is the general phone number for the OSIsoft Technical Support:  

 Phone: +1 510 297-5828 in North America 

 

Support may be provided in languages other than English in certain centres based 
on availability of attendants. If you select a local language option, we will make best 
efforts to connect you with an available Technical Support Engineer with that 
language skill. If no local language tech support engineer is available to assist you, 
you will be routed to the first available attendant. 

Before you contact Technical Support, it is helpful to have certain information readily 
available. OSIsoft technical support engineers will ask: 

• name of the product 

• version number 

• the time that the difficulty started  

• the computer platform (CPU type, operating system, and version number) 

 

  

https://explore.osisoft.com/myosisoft-customer-portal/how-to-get-a-login
https://explore.osisoft.com/myosisoft-customer-portal/how-to-create-a-case-1
https://explore.osisoft.com/myosisoft-customer-portal/how-to-download-prod-1
https://explore.osisoft.com/myosisoft-customer-portal/how-to-find-support--1
https://explore.osisoft.com/myosisoft-customer-portal/administer-your-site
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11.5 Further Questions? 

For questions about Licensing, you can find your account manager listed at 
http://www.osisoft.com/ > Contact Us  

For questions about existing Support Issues, contact technical support (at +1 510 
297-5828) or visit my.osisoft.com 

For questions about unresolved training issues, contact your instructor or email 
learning@osisoft.com. 

For all other questions, please contact our Customer Service group via email at 
customerservice@osisoft.com. 

 

http://www.osisoft.com/
mailto:learning@osisoft.com
mailto:customerservice@osisoft.com
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12. Appendix 

12.1 Exercise Solutions 

12.1.1 PI System Times (Exercise 1.3.6) 

(assume now: Tuesday, 20-May-2014 10:12:23 AM) 

Abbreviation Answer 

* - 30m 20 – May – 2014 09:42:23 AM 

T-1d 19 – May – 2014 12:00:00 AM (midnight) 

y + 8h 19 – May – 2014 08:00:00 

12  8: 12 – May – 2014 08:00:00 

Tuesday – 2d 18 – May – 2014 12:00:00 AM (midnight) 

 

Abbreviation Answer 

Today at 6:30 AM T+6.5h 

Monday at 5:45 am Mon+5.75h 

12 hours ago *-12h 

The first day this 
month 

1 

Tomorrow at 7:00 AM t+31h 

2 hours from now *+2h 

12.1.2 Add a user account to PIMLWindows database (Exercise 3.1.1) 

1. On PISRV01, launch SQL Server Management Studio (SSMS), and connect to PISRV01 

SQL server 

2. Object Explorer > Security > Logins > right click > New Login… 

3. In the Login name field, search for or type in the AD domain group that contains all PI 

Manual Logger users, i.e. PISCHOOL\Students 

4. Verify that Windows Authentication is selected 

5. Go to User Mapping tab > select PimlWindows database 

6. Database role membership: 

• Check db_datareader, db_datawriter, public 

• Uncheck db_owner 

7. OK 

 



Appendix 

 

Page 56 

 

12.1.3 Configure PI Data Archive Security (Exercise 3.2.1) 

1. On PISRV01, launch PI System Management Tools (SMT) 

2. Security > Identities, Users, and Groups 

3. On PI Identities tab, right click > New Identity… 

4. In the Identity field, type in PIMLUser, then Create 

5. Go to Security > Mappings & Trusts 

6. Right click > New Mapping… 

7. In the Windows Account field, search for or type in the AD domain group that contains all 

PI Manual Logger users, i.e. PISCHOOL\Students 

8. In the PI Identity field, select the new identity PIMLUser, then Create 

Note 

• If PIWorld is disabled and the end user is not mapped to any other identities that already 

have permission on the PI Server, then add the PIMLUser identity to PIPOINT Database 

Security with minimum read access. 

o PIWorld is not disabled in this training environment  

• The PIMLUser identity needs access on all (existing and new) PIML tags, i.e. read 

access to point security and read+write access to data security. For bulk create/edit of a 

large number of tags, use PI Builder Excel Add-in. 

o In this training environment, there is no existing PIML tags, so there is nothing for 

us to update in terms of tag security. We will create new PIML tags with the 

necessary permissions in subsequent exercise. 

 

12.1.4 Create PI Digital State Sets and Tags (Exercise 3.2.2) 

1. On PISRV01, launch PI SMT 

2. Points > Digital States 

3. Right click on any state > Import from File > browse to 
"C:\Class\SMT_DigitalStates_PIML.csv" > Create Set(s) 

4. Verify that 3 new sets are created, i.e. Clarity, Open_Closed_NA, and 
Pump_State 

5. Open "C:\Class\PIBuilder_Tags_PIML.xlsx" in Excel 

6. On PI Builder ribbon, select PISRV01 from the Data Server dropdown 

7. Publish > Edit Mode: Create Only 

8. Verify that the publish action completed without errors, and the new PIML tags 
are successfully created. 
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12.1.5 Create PI Manual Logger Users and User Groups (Exercise 3.3.3) 

First, verify your settings by following these steps: 

1. On PISRV01, launch PI Manual Logger PC Client. Log in with user piml and password piml. 
Close the Getting Started window. 

2. Examine the status bar at the bottom of the PIML window to verify the user that is logged 
on, the PI Server you are connected to and the SQL server. 

 

3. By clicking on the user name you can change the user password or switch logged on users. 
4. These options are also available at the top of the PIML window under the PIML menu. 
5. Click on the SQL server status to open the Database connection setup window. 
6. Click on Test and verify that the test is successful. 
7. These steps can also be performed from the PIML menu: Tools > SQL Server Setup 

 

8. From the status bar, verify that you are connected to the desired PI Data Archive server. If 
you need to change the PI Server, go to Tools > PI Data Archive Setup 

9. On the status bar you can also see PIML messages and click on the PIML version to 
display the About PI Manual Logger window and a list of the related software installed. 

 

Next, create the user groups by following these steps: 

1. Click PIML > Manage User Database. The PI Manual Logger User Management window 
appears. 
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2. In the Permission Groups panel, click . The New Permission Group dialog box appears.  
3. Enter the name “Supervisors” in the Group Name field. An entry for the Description field is 

optional. 
4. Click OK to save the new group and close the dialog box. 
5. Follow the same steps to create the “Operators” group. 

 

Users can be created in this same dialog window: 

1. In the Users panel, click . The New User dialog box appears.  
2. Enter the name “Brad” in the User Name field. An entry for the Description field is optional. 
3. Enter a password and confirm it. Then click OK to save the user and close the dialog box. 
4. Repeat the same process to create the users: Tony, Paul and Sam. 

 

Adding a user to a group is simple: 

1. In the Permission Groups panel, double-click the Supervisors group. The Group 
Properties dialog box appears. 

2. Click the User Membership tab. Then click Add. 
3. Select the users Brad, Tony and piml, and click OK. 
4. Click OK to close the Group Properties dialog box. 

 
5. Follow the same procedure to add Paul, Sam and piml to the Operators group. 
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Making the Supervisors the Admin User Group: 

1. On the PIML menu click on Tools and Global Options. 
2. Click on the Security Settings tab. 
3. On the drop down list for the Admin User Group, select Supervisors. 
4. Click OK. 
5. The Supervisors can now create, edit and delete tours. 

 

12.1.6 Create and Configure Tours (Exercise 4.5) 

Start by creating Comment templates: 
1. Use the Tools> Comment Templates option.   
2. In the top pane, Add a new template named LabObservations.   
3. With the new template LabObservations selected, in the bottom pane Add comments 

such as “Sample appears contaminated”, “Ran out of test reagents”, “Sample size too 
small”. 

4. Click OK to save and close the Comment Template Builder   

 
In addition to manual creation, existing digital states from PI can be used. Note that these are 
global, so no tour needs to be selected. A final note, the comment templates provide a “pick 
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list”, but the data entry is not restricted to this. At data entry time, the user can choose a value 
from the template, modify the text or write freeform text entirely. 
 
 

Now create a tour using the Tour Creation Wizard: 

1. Login to PIML with the username Tony, a member of the Supervisors group with right to 
create and edit tours. 

2. Click Tours > New Tour. 
3. The PIML Tour Creation Wizard appears. Click Next. 
4. On the PIML Tour Creation Wizard dialog box, fill in the required information: 

• Tour Name: Lab 

• Tour Description: Control room lab analyses 

5. Click Next, and select the appropriate groups: 

• Full Permission Group: Supervisors 

• Data Entry Only Group: Operators 

6. Click Next, and Add to add the tags that will be collected during the tour. 
7. Search for all tags with a prefix PIML_FinishedProduct by typing PIML_Fin* in the Tag 

Mask field. There will be 4 tags. 
8. Select All tags and click OK. 
9. Click Next and Finish.  
10. You will be taken to the Tour Configuration window.  

 

11. Add Digital state sets to the tour.  To get started, use the  digital 
states bottom at the bottom of the form. Clicking it will bring up the list of System states. 

12. Choose and add (double click, or right click > Add Selected) the states Unit Down, Sample 
Bad and Out of Serv. Click OK to save/close the Tour System States window.   

 

  



Appendix 

 

Page 61 

 

13. Close this window by clicking on the x , in the upper right corner or in the exit icon 

, on the bottom of the form. When prompted to save tour changes, click Yes.   
 
The benefit of using the PIML Tour Creation Wizard is that there is a prompt for you to add 
tags to your tour through the Tag Search dialog box. This completes the Lab tour definition. 
 

 
Create the next tour with the New Tour dialog box (i.e. without using the Wizard): 
1. Click Tours > New Tour. 
2. On the PIML Tour Creation Wizard, check the Skip this wizard box. 
3. Click Next to open the New Tour dialog box and complete the boxes in the dialog box to 

define the tour. 
4. Enter the following information in the window: 

• Tour Name: Reactor 

• Tour Description: This is a reactor tour of Unit 1 

• Full Access Group: Supervisors 

• Data Entry Only Group: Operators 

• Notes: Operators should perform this tour hourly 

5. Click OK. 
6. You will be taken to the Tour Configuration window.  Close this window by clicking on the 

x , in the upper right corner or in the exit icon , on the bottom of the form.  You 
will configure your tour and add tags later. 

 

After tours are created, you can edit the tour and add tags: 

1. Click Tours > Tour List. 

2. Double click on the Reactor tour or select the Reactor tour and click on . 
3. Once in the Tour Configuration dialog box, select the Tag List View window. 
4. You can always close any of these windows and then reopen them by clicking on the View 

icon . 
5. Click on the View icon and ensure that the following windows are open: Tour Info, Tag 

Attributes and Tag List View. 

6. You can now add tags by clicking on the Add new PI Tags… icon . 
7. Search for all tags with a prefix PIML_Reactor by typing PIML_Reactor* in the Tag Mask 

field. There should be 6 tags. 
8. Select All 6 tags and click OK. 
9. You can now see all tags in the tour under the Tag List View window. 

10. Click  at the bottom of the PIML window to save the changes. 

 

Group together tags: 

1. Click the Tag Group Editor icon . 

2. Click the Create a new Group icon . 
3. Type “Reactor control room” and click OK. 
4. Repeat the process and create a “Remote station” group. 
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5. Click OK to save/close the Tag Group Editor window. 

 
6. You will see the new tag groups in the Tag List View window. 
7. Drag the PIML_Reactor_Capacity, PIML_Reactor_Pressure and 

PIML_Reactor_Temperature tags to the Reactor control room group. 
8. Drag the other tags to the Remote station group. 
9. Click on the Reorder Nodes icon and the Reorder Tag Sequence window will open. 
10. Expand the Reactor and select the Reactor control room group. 
11. You will now see the tags in this group on the Tag Sequence Details window on the right.  
12. Using the arrows on the right, reorder the tags until they match the order shown in the 

picture below. This will be the order in which the tags will be collected. (Alternatively, you 
can also drag and drop tags in the Tag List View to reorder sequence.) 

 
 

13. Click  at the bottom of the PIML window to save the changes. 

14. Click  to exit the Tour configuration window. 

 

Following the steps described above, create one more tour with the following 
attributes: 

• Tour Name: Boiler Readings 

• Tour Description: Boiler data  

• Full Access Group: Supervisors 

• Data Entry Only Group: Operators 

• Tags: All tags with the prefix PIML_Boiler (there are 5 tags) 
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12.1.7 Define Collection Schedule and Options (Exercise 4.7) 

To create the hourly collection schedule for the Reactor tour: 

1. Open the Reactor Tour by clicking on Tours > Tour List. 
2. Double click on the Reactor tour. 
3. Click on Set under Tour Scheduling in the Tour Info pane of the Tour Configuration 

dialog window. 
4. Select Clock Scheduling 
5. Click Set 
6. Set the starting date as yesterday 
7. Set the starting time as 5:00 am 
8. Set the ending time as 10:00 am 
9. Set Recurrence pattern: Hourly, every 12 hours 
10. With these settings, the group of tags is due for collection any time between 5:00 am – 

10:00 am and 5:00 pm – 10:00 pm. 
11. Click OK, and click OK again 

12. Click  at the bottom of the PIML window to save the changes. 

 

To configure Tour options: 

1. Click on Tour Options under Notes in the Tour Info pane of the Tour Configuration 
dialog window 

2. Check the “Signature required for each tour run save (on mobile device)”, “Manual data 
must be submitted for approval”, and “Navigate through due tags only (on mobile device)” 
boxes 

3. Uncheck the “Auto Send Data to PI” and “Data Entry Only Group can send data to PI” 
boxes 

4. Click on the Timestamp tab 
5. Select the “Default Tour Time to the Current Timestamp” box 
6. Click OK 
7. Inspect the other tabs and the options available under them. 

8. Click  at the bottom of the PIML window to save the changes. 

 

To create validation limits and trigger actions: 

1. Select the PIML_Reactor_Temperature in the Tag List View. 
2. Select the Data Validation tab. 
3. Enter the following information in the window: 

• LoLo Limit: 150 

• Low Limit: 200 

• High Limit: 420 

• HiHi Limit: 470 

4. Click on the Trigger Action button ( ) for the LoLo Limit. 
5. Select the “Require Comment” check box. 
6. Repeat the steps for the HiHi Limit. 

7. Click on the Trigger Action button ( ) for the Low Limit. 
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8. Select the “Require Signature on device” check box. 
9. Click Yes at the prompting. 
10. Repeat the steps for the High Limit. 

 

Add digital states to the tour: 

1. Click on  at the bottom of the Tour configuration window. 
2. Double click on the following digital sets to add them to the tour: Unit Down and Out of 

Serv. 
3. Click OK when done. 

4. Click  at the bottom of the PIML window to save the changes. 
 
 

12.1.8 Conditional Data Entry and Operator Instruction (Exercise 4.8) 

To edit the tour: 

1. Log in as an admin user – such as Tony. 
2. Open the Tour List by clicking Tours > Tour List 
3. Open the Reactor tour previously created 
4. Using the Tag List View, select the PIML_Reactor_Capacity tag 
5. Click on Tag Entry Options 
6. Under Conditional Specification type the equation:  

• If(CurrentValue("PIML_Reactor_Pressure") >10 ||  
CurrentValue("PIML_Reactor_Pressure") ==DigCode("Unit Down") ,Skip(),CollectNow()) 

The || symbol is the Or operator. 

Note: CMDE can be defined for an individual tag or for a group of tags. CMDE for individual 
tags takes precedence over any group CMDE. Please see Supported Functions in the PI 
Manual Logger User Guide, for a complete list of supported functions. 

To activate the editor's IntelliSense feature, use these key combinations: 

Ctrl + Shift. Prompts with a list of CMDE functions along with their descriptions. 

Ctrl + t. Prompts with a list of tags in the tour. 

Ctrl + o. Prompts with a list of CMDE operators. 

7. Enter the same Conditional Specification for the PIML_Reactor_ValveOut1, 
PIML_Reactor_ValveOut2, and PIML_Reactor_CW_Intake tags. 

8. Navigate to the PIML_Reactor_ValveOut1 tag. 
9. In the Tag Configuration tab and in the Operator Instructions box type: “Ensure both 

relief valves are closed but unlocked during normal operations”. 

10. Click  at the bottom of the PIML window to save the changes. 

  

 

https://docs.osisoft.com/bundle/pi-manual-logger/page/supported-functions-for-conditional-manual-data-entry-cmde.html
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Note:  It is possible to insert a hyperlink to a file or an HTTP website or an FTP site in the 
operator instructions. Multiple hyperlinks can appear in operator instructions used for tour runs 
executed on a PC, and the operator can choose the hyperlink to open. Operator instructions for 
mobile devices can contain only one working hyperlink. 

If the operator enters a value for a tag and then accesses the tag a second time, the operator 
instructions do not open automatically. However, the operator can click to display them again. 

 

12.1.9 Export and Import Tour Configuration (Exercise 4.9) 

1. Go to Tours > Tour List. 
2. Select all the tours in your list. 
3. Click on Export. 
4. When the Export Tour Definitions dialog box opens, browse or type the location and 

name of an XML file. 
5. Click OK. 
6. You can save or close the export log. 
7. Open the PIML tour configuration schema file located in  

C:\Program Files (x86)\PIPC\PimlWindows\OSIsoft.PIML.TourConfigurations.xlsx 
8. Once the file is open in Excel you will have a workbook with 4 worksheets. Make sure the 

Developer tab is open, otherwise in Excel go to File > Options > Customize Ribbon > Main 
Tabs > check Developer > OK. 

9. Under the Developer tab in the XML group, click on Import and open the XML exported 
from PIML. 

10. In the first worksheet you will see the tour information, the second sheet contains the tour 
options, the third sheet contains tag groups, and the last sheet contains the tags to be 
collected. 

11. Go to the last worksheet titled PIML Tags, find the PIML_Reactor_Temperature tag in the 
Reactor tour. Go to the column containing the HiHi limit of 470 and change it to 500. 

12. Find the 4 tags in Lab tour, and change their values of the Sequence column: 1 for pH, 2 for 
Density, 3 for BoilingPoint and 4 for Appearance.  

13. Under the Developer tab in the XML group, click on Export and provide a new name for 
the XML file such as tourstobeimported.xml. 

14. Return to PIML and go to Tours > Tour List. 
15. Click on Import, browse to and select the new/modified XML file, click OK to begin import. 

When the import is complete close the logs. 
16. Open the Reactor tour and navigate to the PIML_Reactor_Temperature tag. 
17. Go to the Data Validation tab and inspect the HiHi Limit to ensure the value was changed to 

500. 
18. Open the Lab tour and verify the tag sequence in the Tag List View. 
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12.1.10 Create and Save Tour Runs (Exercise 5.1) 

Create a tour run for the Reactor tour: 

1. Log in as an operator user – such as Sam. 
2. Go to Tours > Tour Run List 
3. Select the Reactor tour and click on New Tour Run 
4. When the New Tour Run window is displayed, set the time stamp to yesterday at 9:00 PM. 

The reason for choosing this specific timestamp is because we want to simulate tag due for 
data collection based on tour scheduling (5am-10am or 5pm-10pm), but depending on 
when this exercise is done the current timestamp may not fall within that range. 

5. Click OK 
6. The tour run opens and the first tag is displayed in the Data Entry Form. 
7. Notice that all tags will have a red ? icon by the tags in the tag list view, indicating they are 

due for data collection. 
8. Enter 1300 in the Tag Value field for the PIML_Reactor_Pressure. Use the previous values 

tab in the right pane to review historical data. Double-click the adhoc trend to see historical 
data from this tag. Pan back in time, zoom and revert – just like a ProcessBook trend. Click 

 at the bottom of the PIML window to move to the next tag. 

9. Enter 100 in the Tag Value field for the PIML_Reactor_Temperature and click  at the 
bottom of the PIML window.    

10. A warning window will be displayed saying the Low and LoLo limits have been violated. 
11. Click OK. 
12. A warning window will be displayed saying that you are required to enter a comment for the 

tag. 
13. Click OK 
14. Type: “Temperature is low due to startup of Reactor” in the Value Comment field of the tag. 

15. Click  at the bottom of the PIML window again. 
16. Again, the same warning window will be displayed saying the Low and LoLo limits have 

been violated. 
17. Click OK and now the Data Entry Form for the next tag will be displayed. 
18. PIML displays the next tag, however these tags do not need to be collected according to 

the conditional data collection (CMDE). In the PIML mobile device, tags that are not due for 
collection are not displayed. In PIML PC Client, these tags will have an X icon by the tags in 
the tag list view. This is also a good example of the more “specific” tag level option taking 
priority over the entire tour option (tour scheduling). Initially, the last 4 tags were also due 
based on tour scheduling, but CMDE logic (at tag level) now determines that they are no 
longer due for collection. 

19. Click Save  and Exit . 
20. In the Tour Run List pane, you should see that the Status of this tour run is Completed. 
21. Repeat the process by creating a new tour run for the Reactor tour. 
22. Set the time stamp to 1 hour ago. It does not matter if this time stamp leads to tags due for 

collection or not. If tags are not due for collection, they will have an X icon by them in the 
tag list view. Regardless, you can still continue to collect data because PIML does not 
enforce it, i.e. it does not stop you from collecting data. 

23. Enter the following values (you can also try to use the Data Entry Sheet tab): 

• PIML_Reactor_Pressure: 8.5 

• PIML_Reactor_Temperature: 405 
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• PIML_Reactor_Capacity : 60.7 

• PIML_Reactor_ValveOut2: Closed (select from Tag Value field dropdown) 

• PIML_Reactor_ValveOut1: Closed (select from Tag Value field dropdown) 

• PIML_Reactor_CW_Intake: 75 

24. Click Save  and Exit . 
25. In the Tour Run List pane, you should see that the Status of this tour run is Completed. 

Note:  Save and exit is done as Send to PI restricted. Data will be sent after approval. 

 
 
Create a tour run for the Lab tour: 
 
1. Following similar steps as above, set the tour run time stamp to 1 hour ago, and enter the 

following values for the tags in the Lab tour: 

• PIML_FinishedProduct_pH: Out of Serv (select from Tag Value field 
dropdown) 

o Next to the Value Comment field, click Use Comment Templates…, 
click the >> arrow button, choose the LabObservations comment 
template, double click “Ran out of test reagents” 

o Type additional comments (free text) at the end – “They have been 
reordered.” 

o Click OK 

 
• PIML_FinishedProduct_Density: 1.7 

• PIML_FinishedProduct_BoilingPoint: 200 

• PIML_FinishedProduct_Appearance: Clear 
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2. Choose SendtoPI   (Unlike the Reactor tour, no approval is needed for Lab tour so a 
direct SendtoPI is possible). Verify the message at the status bar at the bottom of PIML 
window: “Data successfully sent to PI”. 

• Even if you click Save  and then Exit , Lab tour run data will still be 
sent to PI directly, because tour option “Auto Send Data to PI” is True and 
there is no approval process configured for this Lab tour. 

3. Exit . 
4. In the Tour Run List pane, you should see that the Status of this tour run is Archived. 
 
 
Create a tour run for the Boiler tour: 
 
1. Following similar steps as above, set the tour run time stamp to 1 hour ago, and enter the 

following values for the tags in the Boiler tour: 

• PIML_Boiler_Drum_Level: 50 

• PIML_Boiler_Pressure_Outlet: 700 

• PIML_Boiler_Temperature_Outlet: 300 

• PIML_Boiler_ValveOut1: Open 

• PIML_Boiler_ValveOut2: Closed 
 

2. Choose SendtoPI   (Unlike the Reactor tour, no approval is needed for Boiler tour so a 
direct SendtoPI is possible). 

3. Exit . 
4. In the Tour Run List pane, you should see that the Status of this tour run is Archived. 
 
 
 
Review data in PI with PI DataLink (PI SMT can also be used for similar purpose): 
 
1. Open a new Excel sheet and select cell A1 
2. Go to the PI DataLink ribbon, and click the Search icon to do a tag search 
3. Navigate to PISRV01 PI Data Archive, insert tagmask of PIML*, and then click Search 
4. Select all Reactor, Lab and Boiler tags, then click OK 
5. Select cell B1, and click the Current Value button on the PI DataLink ribbon 
6. Data item: highlight tag list on worksheet 
7. Choose the “Time at left” option, and click OK 
8. Verify that Lab and Boiler tags have data from the tour runs 
9. Verify that Reactor tags do not have data yet (values still show Pt Created), because 

Reactor data has not been approved. 
10. To see the comments from the Lab tour run for the PIML_FinishedProduct_pH tag, use 

the Compressed Data function on a separate/empty cell. Fill in the data item, start time, 
and end time fields, and check the “Show time stamps” and “Show annotations” boxes. 
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12.1.11 Create and Save Tour Runs with future data (Exercise 5.3) 

1. Tours > Tour Run List 
2. Select Lab tour > New Tour Run 
3. Put a timestamp of 20-30 minutes into the future. 
4. Enter the following values for the tags in the Lab tour:  

• PIML_FinishedProduct_pH: 1.4 

• PIML_FinishedProduct_Density: 5 

• PIML_FinishedProduct_BoilingPoint: 250 

• PIML_FinishedProduct_Appearance: Cloudy 
5. Choose Save, and then Exit 
6. Notice that in the Tour Run List pane, the Status of this tour run is Queued. 
7. Check with PI DataLink or PI SMT that future data is not sent to PI.  
8. Wait for the timestamp of the queued data to become current, then go to PIML > PI Tags 

and Digital States > Queued Data tab > select row(s) > Send Queued Data to PI 
9. Check with PI DataLink or PI SMT again that data is now in PI. 
10. Tour run status has now changed from Queued to Archived. 

 

12.1.12 Approve the Data for the PI Archive (Exercise 6.1.1) 

1. Log in to PIML PC Client as a supervisor user – Brad. 
2. Tours > Tour Run List 
3. Select the Reactor tour from the top panel 
4. From the bottom panel, double click a Completed tour run to open it. 
5. Click “Yes” when prompted with “Do you want to review/modify the completed tour run?” 
6. Review/modify tour run data as necessary. You can modify or remove any bad values. You 

can also add or edit any comments. 
7. Click Approve 
8. The Data Entry window automatically closes, and the tour run status changes from 

Completed to Archived 
9. (optional) Repeat for remaining completed tour run(s) 
10. Use PI DataLink or PI SMT to verify Reactor data has been sent to PI 

 

12.1.13 Enter and Save data with PI Manual Logger Web (Exercise 9.2.1) 

Collect the data: 

1. On PICLIENT01, open Google Chrome 
2. Navigate to https://piweb01/piml.web or use the bookmark saved 
3. If the home page says “Tours Not Found”, click the Refresh button on the top right corner, 

and click Yes on the prompt. 
4. In general, if the Refresh button says “Updates Available”, it means Tour Configuration has 

changed. So we should always Refresh to get the latest configuration. 
5. Select the Boiler tour.   
6. Click the New Tour Run button. 
7. Change the tour run timestamp to 2 hours ago 
8. Enter 45 for the first tag, PIML_Boiler_Drum_Level 

  

https://piweb01/piml.web
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9. Click the arrow to move to the next tag. 
10. Enter 680 for the second tag, PIML_Boiler_Pressure_Outlet. Enter a comment “Pressure 

sensor needs maintenance.” 
11. “Switch to grid data entry view” from top right corner 
12. Enter the remaining tags with the following values: 

· PIML_Boiler_Temperature_Outlet: 350  

· PIML_Boiler_ValveOut1: Closed 

· PIML_Boiler_ValveOut2: Closed 
13. Click Save and Exit. Notice the small green prompt at the top right corner that says “Data 

was saved successfully” 

 

Change a tag value of previous/recent tour run: 

1. Select the Boiler tour again.   
2. Choose the tour run by time from the list below. 
3. Update the value for PIML_Boiler_Drum_Level to 40. 
4. Click on Save and Exit. 

 
Confirm the data is saved to PI: 

1. Open Excel 
2. Using the PI Datalink Compressed Data (or Current Value), find the values for each tag of 

the tour. 
3. When using Compressed Data function for the PIML_Boiler_Drum_Level tag, also check 

the “Show value attributes” box. This returns the value “S” in an additional column, which 
means the tag value was substituted (from original 45 to 40). 

 

Simulate offline data collection: 

1. On the Google Chrome browser within PICLIENT01, hit F12 to open the Developer tool. 
2. In the Network tab, change the following drop down box from “No throttling” to “Offline”. 

 
3. Notice that the top right corner of PIML web homepage shows “Offline” and the Refresh 

button is greyed out. 
4. Select the Boiler tour and start a New Tour Run 
5. Enter values for all the 5 tags. 
6. Save and Exit. Notice the small green prompt at the top right corner that says “Data was 

saved locally” 
7. Verify with PI DataLink that this set of data is not sent to PI 
8. Change the network tab dropdown back to “No throttling”. 
9. Notice that the top right corner of PIML web homepage shows “Online” and the Refresh 

button is active again 
10. Click Refresh and then Yes, to send tour run data from the local browser storage to PI. 
11. Notice the small green prompt at the top right corner that says “Data was saved 

successfully” 
12. Using PI DataLink, confirm this set of data is now in PI. 
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